Add php-dom extension for CentOs platform. #10

Merged
merged 1 commit into from Feb 12, 2013

Conversation

Projects
None yet
2 participants
Contributor

dkinzer commented Feb 11, 2013

The build fails on my CentoOs6.3 base box because drush install throws
an Exception when it does not find the php-dom extension.

The minimum PHP package on CentOs does not include the php-dom extension by default.

Note there is no php:module_dom recipe to add via the requirement stament. Also, the
maintainer of the php cookbook has depricated all the module_
recipes, and is asking developers that require these extensions to include them via a call to package as I do here.

@dkinzer dkinzer Add php-dom extension for CentOs platform.
The build fails on my CentoOs6.3 base box because drush install throws
an Exception when it does not find the php-dom extension.

The minimum PHP package on CentOs does not include the php-dom extension by default.

Note there is no php:module_dom recipe to add via the requirement stament.  Also, the
maintainer of the php cookbook has depricated all the module_<extension>
recipes, and is asking developers that require these extensions to include them via a call to package as I do here.
17800f0

mdxp commented on 17800f0 Feb 11, 2013

Thanks @dkinzer for this. qq: is this required by drush itself or the install site command? Also is the package called the same for centos5?

@mdxp I think it's a requirement for drupal, but the exception get's thrown when drush-install install drupal core.

The package is the same name for centos5.

mdxp merged commit a0cb31c into promet:master Feb 12, 2013

1 check failed

default The Travis build failed
Details

dkinzer deleted the jenkinslaw:add-php-dom branch Feb 12, 2013

Contributor

dkinzer commented Feb 12, 2013

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment