Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

5.4 and up :) #300

Merged
merged 1 commit into from

3 participants

@harikt

I would have loved to mention Propel follows PSR-0, 1, 2 for its following ( I hope its following ).

But if so it will not be pointing to wiki. Do we need to edit the wiki then ( currently it mentions symfony standards ) ?

@travisbot

This pull request passes (merged 7482ca3 into 99e125e).

@willdurand
Owner

Great!

@willdurand willdurand merged commit c8dcbc9 into propelorm:master
@willdurand
Owner

Yes we should edit the Wiki.

@harikt

Do we want to copy the PSR-1 and PSR2 of php-fig to wiki , or should we point to it ?

@willdurand
Owner
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 25, 2012
  1. @harikt

    5.4 and up :)

    harikt authored
This page is out of date. Refresh to see the latest.
Showing with 4 additions and 6 deletions.
  1. +0 −2  .travis.yml
  2. +2 −2 README.md
  3. +2 −2 composer.json
View
2  .travis.yml
@@ -1,8 +1,6 @@
language: php
php:
- - 5.3.3
- - 5.3
- 5.4
env:
4 README.md
@@ -1,6 +1,6 @@
# Propel2 #
-Propel2 is an open-source Object-Relational Mapping (ORM) for PHP 5.3.
+Propel2 is an open-source Object-Relational Mapping (ORM) for PHP 5.4.
[![Build Status](https://secure.travis-ci.org/propelorm/Propel2.png?branch=master)](http://travis-ci.org/propelorm/Propel2)
@@ -18,7 +18,7 @@ Propel2 uses the following Symfony2 Components:
Propel2 also relies on [**Composer**](https://github.com/composer/composer) to manage dependencies but you
also can use [ClassLoader](https://github.com/symfony/ClassLoader) (see the `autoload.php.dist` file for instance).
-Propel2 is only supported on PHP 5.3.3 and up.
+Propel2 is only supported on PHP 5.4 and up.
## Installation ##
View
4 composer.json
@@ -1,7 +1,7 @@
{
"name": "propel/propel",
"type": "library",
- "description": "Propel2 is an open-source Object-Relational Mapping (ORM) for PHP 5.3",
+ "description": "Propel2 is an open-source Object-Relational Mapping (ORM) for PHP 5.4",
"keywords": [
"ORM",
"persistence",
@@ -16,7 +16,7 @@
}
],
"require": {
- "php": ">=5.3.3",
+ "php": ">=5.4",
"symfony/yaml": "2.1.*",
"symfony/console": "2.1.*",
"monolog/monolog": "1.0.*",
Something went wrong with that request. Please try again.