Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

propel:fixtures:load results in fatal error #124

Closed
bmeynell opened this Issue · 3 comments

4 participants

@bmeynell
php app/console propel:fixtures:load --env=dev
[Propel] You are running the command: propel:fixtures:load  

Use connection named default in dev environment.
No SQL fixtures found.
No XML fixtures found.
Use connection named default in dev environment.
Fatal error: require(): Cannot redeclare class tablemap in /var/www/beta.myproject.com/src/vendor/symfony/src/Symfony/Component/ClassLoader/DebugUniversalClassLoader.php on line 56

Call Stack:
    0.0002     651192   1. {main}() /var/www/beta.myproject.com/app/console:0
    0.0144    3411864   2. Symfony\Component\Console\Application->run() /var/www/beta.myproject.com/app/console:20
    0.0163    3736880   3. Symfony\Bundle\FrameworkBundle\Console\Application->doRun() /var/www/beta.myproject.com/src/vendor/symfony/src/Symfony/Component/Console/Application.php:106
    0.0953   17373376   4. Symfony\Component\Console\Application->doRun() /var/www/beta.myproject.com/src/vendor/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php:77
    0.0975   17373376   5. Symfony\Component\Console\Command\Command->run() /var/www/beta.myproject.com/src/vendor/symfony/src/Symfony/Component/Console/Application.php:193
    0.0979   17374928   6. Propel\PropelBundle\Command\FixturesLoadCommand->execute() /var/www/beta.myproject.com/src/vendor/symfony/src/Symfony/Component/Console/Command/Command.php:237
    0.1001   17530040   7. Propel\PropelBundle\Command\FixturesLoadCommand->loadFixtures() /var/www/beta.myproject.com/src/vendor/bundles/Propel/PropelBundle/Command/FixturesLoadCommand.php:147
    0.1014   17723152   8. Propel\PropelBundle\DataFixtures\Loader\AbstractDataLoader->load() /var/www/beta.myproject.com/src/vendor/bundles/Propel/PropelBundle/Command/FixturesLoadCommand.php:183
    0.1014   17723544   9. Propel\PropelBundle\DataFixtures\AbstractDataHandler->loadMapBuilders() /var/www/beta.myproject.com/src/vendor/bundles/Propel/PropelBundle/DataFixtures/Loader/AbstractDataLoader.php:57
    2.2778   27694064  10. Propel\PropelBundle\DataFixtures\AbstractDataHandler->guessFullClassName() /var/www/beta.myproject.com/src/vendor/bundles/Propel/PropelBundle/DataFixtures/AbstractDataHandler.php:71
    2.2780   27695912  11. class_exists() /var/www/beta.myproject.com/src/vendor/bundles/Propel/PropelBundle/DataFixtures/AbstractDataHandler.php:102
    2.2780   27696464  12. Symfony\Component\ClassLoader\DebugUniversalClassLoader->loadClass() /var/www/beta.myproject.com/src/vendor/bundles/Propel/PropelBundle/DataFixtures/AbstractDataHandler.php:0
@havvg
Collaborator

Do you have installed the vendors of the PropelBundle? If so, remove them from an actual project.

@dustinwhittle

The issue is in the autoloader. This issue can be closed.

@willdurand
Owner

Ok, thanks Dustin :)

@willdurand willdurand closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.