Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Allow Symfony >2.1 in the 1.2 branch #250

Merged
merged 1 commit into from

2 participants

@ClementGautier

No description provided.

composer.json
@@ -9,7 +9,7 @@
"email": "william.durand1@gmail.com"
}],
"require": {
- "symfony/symfony": "~2.2",
+ "symfony/symfony": ">=2.2.0",
@willdurand Owner

not a good idea.

@willdurand What would be the good requirement here for you ?

@willdurand Owner

~2.2 is ok

rolled back

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@willdurand willdurand merged commit 747299c into propelorm:1.2
@willdurand
Owner

thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Sep 30, 2013
  1. @ClementGautier

    Allow Symfony >2.1 in the 1.2 branch

    ClementGautier authored ClementGautier committed
This page is out of date. Refresh to see the latest.
Showing with 8 additions and 2 deletions.
  1. +6 −0 .travis.yml
  2. +2 −2 README.markdown
View
6 .travis.yml
@@ -5,12 +5,18 @@ php:
- 5.4
- 5.5
+env:
+ - SYMFONY_VERSION=2.2.*
+ - SYMFONY_VERSION=2.3.*
+ - SYMFONY_VERSION=dev-master
+
matrix:
allow_failures:
- php: 5.5
before_script:
- curl -s http://getcomposer.org/installer | php
+ - php composer.phar require symfony/symfony:${SYMFONY_VERSION} --no-update
- php composer.phar --dev install
script: phpunit --coverage-text
View
4 README.markdown
@@ -11,14 +11,14 @@ As `Propel2` will be released in the near future, we are migrating the branching
* The `1.0` branch contains Propel *1.6* integration for Symfony *2.0* (*currently 2.0 branch*).
* The `1.1` branch contains Propel *1.6* integration for Symfony *2.1* (*currently 2.1 branch*).
-* The `1.2` branch contains Propel *1.6* integration for Symfony *2.2* (*currently master branch*).
+* The `1.2` branch contains Propel *1.6* integration for Symfony *>2.1* (*currently 2.2, 2.3 and 2.4 branch*).
* The `2.0` branch will contain `Propel2` integration for Symfony *2.1*.
We are still considering to integrate `Propel2` with Symfony *2.0*.
In case, we will do so, there will be a `2.1` and `2.0` branch integrating the respective Symfony version!
**The 1.x branches are already available and you are encouraged to migrate your dependencies according to the listings!**
-* If you depend on Symfony `master` branch, switch to the `1.2` branch.
+* If you depend on Symfony `2.2`, `2.3` or `master` branch, switch to the `1.2` branch.
* If you depend on Symfony `2.1` branch, switch to the `1.1` branch.
* If you depend on Symfony `2.0` branch, switch to the `1.0` branch.
Something went wrong with that request. Please try again.