Skip to content
This repository

Here is the PropelBundle's wiki.

Branching Model

As Propel2 will be released in the near future, we are migrating the branching model of this bundle in advance!

  • The 1.0 branch will contain Propel 1.6 integration for Symfony 2.0.
  • The 1.1 branch will contain Propel 1.6 integration for Symfony 2.1.
  • The 1.2 branch will contain Propel 1.6 integration for Symfony 2.2 (currently master branch).
  • The 2.0 branch will contain Propel2 integration for Symfony 2.1. We are still considering to integrate Propel2 with Symfony 2.0. In case, we will do so, there will be a 2.1 and 2.0 branch integrating the respective Symfony version!

The 1.x branches are already available and you are encouraged to migrate your dependencies according to the listings!

  • If you depend on the master branch, switch to the 1.2 branch.
  • If you depend on the 2.0 branch, switch to the 1.0 branch.

Note: the master, and 2.0 branches won't be updated anymore, and will trigger a E_USER_DEPRECATED error to notice people.

How to migrate?

You are using the Symfony2 vendor management:

  • Symfony2 2.0.x: use version=origin/1.0 instead of version=origin/2.0.
  • Symfony2 2.1: use version=origin/1.1 instead of no version.
  • Symfony2 2.2: use version=origin/1.2 instead of no version.

You are using Composer:

  • Symfony2 2.0.x: use the 1.0.* constraint instead of a tag;
  • Symfony2 2.1: use the 1.1.* constraint instead of a tag or dev-master.
  • Symfony2 2.1: use the ~1.2.0 constraint instead of a tag or dev-master.

You are using Git submodules:

  • Symfony2 2.0.x: use the a712d9e4aa commit;
  • Symfony2 2.1: use the 36a9247222 commit.

You are using ZIP files:

You are using TAR files:

Explanation about the version numbers

In PropelBundle's context, branches are versions; Not just because of Composer but because it really makes sense. And, we have to use our own lifecycle, not the Symfony2 one.

That's why the 1.0 branch represents the "first version" of the PropelBundle, the code written a year ago. It supports Symfony2 2.0.x only.

Then, we improved the bundle thanks to contributors. As we broken BC, we released a new version: 1.1. But, as we are still using Propel 1.6, we are just increasing the version number by one. Let's say the first number is the Propel major version, and the second number is the bundle's version.

When we will break BC again by introducing Propel2, it will be time to increase the first number, as we will use the second major version of Propel: 2.0. If we still support Symfony2 2.0.x (which not makes sense IMO), then we will use a branch 2.0, and 2.1 for Symfony2 >= 2.1. Otherwise, we will use 2.0 for Propel2 + Symfony2 >= 2.1.

Something went wrong with that request. Please try again.