Here is the PropelBundle's wiki.
Propel2 will be released in the near future, we are migrating the branching model of this bundle in advance!
1.0branch will contain Propel 1.6 integration for Symfony 2.0.
1.1branch will contain Propel 1.6 integration for Symfony 2.1.
1.2branch will contain Propel 1.6 integration for Symfony 2.2 (currently master branch).
2.0branch will contain
Propel2integration for Symfony 2.1. We are still considering to integrate
Propel2with Symfony 2.0. In case, we will do so, there will be a
2.0branch integrating the respective Symfony version!
The 1.x branches are already available and you are encouraged to migrate your dependencies according to the listings!
masterbranch, switch to the
2.0branch, switch to the
2.0 branches won't be updated anymore, and will trigger a
E_USER_DEPRECATED error to notice people.
You are using the Symfony2 vendor management:
version=origin/1.1instead of no version.
version=origin/1.2instead of no version.
You are using Composer:
1.0.*constraint instead of a tag;
1.1.*constraint instead of a tag or
~1.2.0constraint instead of a tag or
You are using Git submodules:
You are using ZIP files:
You are using TAR files:
In PropelBundle's context, branches are versions; Not just because of Composer but because it really makes sense. And, we have to use our own lifecycle, not the Symfony2 one.
That's why the
1.0 branch represents the "first version" of the PropelBundle, the code written a year ago. It supports Symfony2 2.0.x only.
Then, we improved the bundle thanks to contributors. As we broken BC, we released a new version:
1.1. But, as we are still using Propel 1.6, we are just increasing the version number by one. Let's say the first number is the Propel major version, and the second number is the bundle's version.
When we will break BC again by introducing Propel2, it will be time to increase the first number, as we will use the second major version of Propel:
2.0. If we still support Symfony2 2.0.x (which not makes sense IMO), then we will use a branch
2.1 for Symfony2 >= 2.1. Otherwise, we will use
2.0 for Propel2 + Symfony2 >= 2.1.
Last edited by willdurand,