Browse files

Merge pull request #163 from bugbyte/master

Support installation with Composer
  • Loading branch information...
2 parents 67a3936 + 7341859 commit ed8361bff333dd954717f0f1774533d017b54a46 @willdurand willdurand committed Oct 2, 2012
Showing with 30 additions and 0 deletions.
  1. +14 −0 README.md
  2. +16 −0 composer.json
View
14 README.md
@@ -7,6 +7,20 @@ Replaces symfony's core Propel plugin by the latest version of Propel, in branch
## Installation
+### The Composer way
+
+Add the require to your composer.json. It's oddly named but like this Composer's symfony1 installer camelcases it correctly.
+Composer will install it into your project's plugins directory automatically, and add the requirements.
+
+ {
+ "config": {
+ "vendor-dir": "lib/vendor"
+ },
+ "require": {
+ "propel/sf-propel-o-r-m-plugin": "dev-master"
+ }
+ }
+
### The Git way
Clone the plugin from Github:
View
16 composer.json
@@ -0,0 +1,16 @@
+{
+ "name": "propel/sf-propel-o-r-m-plugin",
+ "type": "symfony1-plugin",
+ "description": "symfony 1.x plugin for Propel.",
+ "keywords": ["symfony", "propel", "orm", "active record", "mapping", "database", "persistence"],
+ "homepage": "http://www.propelorm.org/",
+ "require": {
+ "composer/installers": "*",
+ "propel/propel1": "1.6.*"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.5-dev"
+ }
+ }
+}

0 comments on commit ed8361b

Please sign in to comment.