Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

chore(6.x): release 6.11.3 #1737

Merged
merged 1 commit into from May 20, 2022

Conversation

github-actions[bot]
Copy link
Contributor

@github-actions github-actions bot commented May 20, 2022

馃 I have created a release beep boop

6.11.3 (2022-05-20)

Bug Fixes


This PR was generated with Release Please. See documentation.

@bcoe bcoe merged commit b130dfd into 6.x May 20, 2022
@github-actions
Copy link
Contributor Author

github-actions bot commented May 20, 2022

馃 Release is at https://github.com/protobufjs/protobuf.js/releases/tag/v6.11.3 馃尰

alexander-fenster added a commit that referenced this issue Jul 7, 2022
* feat: proto3 optional support

* chore: pre-release v6.11.0-pre

* fix: rebuild

* fix: fromObject should not initialize oneof members (#1597)

* test: adding test for pbjs static code generation

* fix: fromObject should not initialize oneof members

* chore: release v6.11.0

* chore: rebuild

* feat: add --no-service option for pbjs static target (#1577)

This option skips generation of service clients.

Co-authored-by: Alexander Fenster <fenster@google.com>

* deps: set @types/node to >= (#1575)

* deps: set @types/node to star version

When using `protobuf.js` as a dependency in a project it is important
that `@types/node` package gets de-duped and has the same version as for
the rest of the modules in the project. Otherwise, typing conflicts
could happen as they do between v13 and v14 node types.

* fix: use @types/node >=13.7.0

* fix: use @types/node >=13.7.0

Co-authored-by: Alexander Fenster <fenster@google.com>
Co-authored-by: Alexander Fenster <github@fenster.name>

* chore: rebuild

* docs: update changelog

* fix: parse.js "parent.add(oneof)鈥 error (#1602)

Co-authored-by: xiaoweili <xiaoweili@tencent.com>

* chore: release v6.11.1

* fix(types): bring back Field.rule to .d.ts

* fix: rebuild type, release v6.11.2

* build: configure backports

* build: configure 6.x as default branch

* fix: do not let setProperty change the prototype (#1731)

* fix(deps): use eslint 8.x (#1728)

* build: run tests if ci label added (#1734)

* build: publish to main

* chore(6.x): release 6.11.3 (#1737)

Co-authored-by: github-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>

* Support parsing of complex options

* Use readValue to read the proto value and add better example

* Fix lint issues

* fix: rollback files

* Re-do parse logic to take arrays into account and make it simpler

Co-authored-by: Alexander Fenster <fenster@google.com>
Co-authored-by: Matthew Douglass <5410142+mdouglass@users.noreply.github.com>
Co-authored-by: Fedor Indutny <fedor.indutny@gmail.com>
Co-authored-by: Alexander Fenster <github@fenster.name>
Co-authored-by: leon <leon776@users.noreply.github.com>
Co-authored-by: xiaoweili <xiaoweili@tencent.com>
Co-authored-by: Benjamin Coe <bencoe@google.com>
Co-authored-by: github-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

1 participant