Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Stop building binary gems for ruby <2.5. #7453

Merged
merged 1 commit into from May 1, 2020

Conversation

haberman
Copy link
Member

@haberman haberman commented May 1, 2020

It is no longer possible to "bundle install" these versions:

$ bundle install
Fetching gem metadata from https://rubygems.org/.................
reline-0.1.3 requires ruby version >= 2.5, which is incompatible with the current version, ruby 2.4.9p362

It is no longer possible to "bundle install" these versions:

$ bundle install
Fetching gem metadata from https://rubygems.org/.................
reline-0.1.3 requires ruby version >= 2.5, which is incompatible with the current version, ruby 2.4.9p362
@haberman haberman requested a review from TeBoring May 1, 2020
@haberman haberman added ruby release notes: yes labels May 1, 2020
@haberman haberman merged commit e19bfc0 into protocolbuffers:3.12.x May 1, 2020
1 of 2 checks passed
benwh added a commit to gocardless/fluent-plugin-gcloud-pubsub-custom that referenced this issue May 17, 2020
CI message from `bundle install`:
```
google-protobuf-3.12.0-x86_64-linux requires ruby version >= 2.5, which is
incompatible with the current version, ruby 2.4.6p354
```

protocolbuffers/protobuf#7453
benwh added a commit to gocardless/fluent-plugin-gcloud-pubsub-custom that referenced this issue May 17, 2020
CI message from `bundle install`:
```
google-protobuf-3.12.0-x86_64-linux requires ruby version >= 2.5, which is
incompatible with the current version, ruby 2.4.6p354
```

protocolbuffers/protobuf#7453
benwh added a commit to gocardless/fluent-plugin-gcloud-pubsub-custom that referenced this issue May 17, 2020
CI message from `bundle install`:
```
google-protobuf-3.12.0-x86_64-linux requires ruby version >= 2.5, which is
incompatible with the current version, ruby 2.4.6p354
```

protocolbuffers/protobuf#7453
@uyu423
Copy link

@uyu423 uyu423 commented May 18, 2020

@haberman

We are using Amazon Linux 4.14.1 for Node.js and yum repository. For that OS image, it only supports installation up to ruby 2.4. All environments are using similar versions of Amazon Linux images and this will be affected to all our server. So this feature appears to be critical issues.

benwh added a commit to gocardless/fluent-plugin-gcloud-pubsub-custom that referenced this issue May 18, 2020
Ruby 2.4 is now end-of-life. As a result of this, the `google-protobuf`
gem is no longer releasing artifacts compatible with this version.
(protocolbuffers/protobuf#7453)

In CI we encounter this error from `bundle install`:
```
google-protobuf-3.12.0-x86_64-linux requires ruby version >= 2.5, which is
incompatible with the current version, ruby 2.4.6p354
```

Therefore remove Ruby 2.4.6 as a tested version in Travis CI.

Additionally remove the constraint on patch versions in the Travis
config, so that we'll use the latest patch version available for each
release branch.
calvinaditya95 added a commit to calvinaditya95/fluent-plugin-gcloud-pubsub-custom that referenced this issue Jan 5, 2021
* Set a default ruby version

* Remove deprecated has_rdoc option

This has been deprecated [since 2011][0]

[0]: https://github.com/rubygems/rubygems/blob/1aebd7ddd69c9a38aa9daa3aa89f396d59c9e2a4/History.txt#L3296-L3297

* Add rubocop configuration

* Add rubocop fixups and configuration

Use the rubocop generated configuration to ignore any major changes that
can't be auto-corrected.

* Adjust supported Ruby versions

Ruby 2.4 is now end-of-life. As a result of this, the `google-protobuf`
gem is no longer releasing artifacts compatible with this version.
(protocolbuffers/protobuf#7453)

In CI we encounter this error from `bundle install`:
```
google-protobuf-3.12.0-x86_64-linux requires ruby version >= 2.5, which is
incompatible with the current version, ruby 2.4.6p354
```

Therefore remove Ruby 2.4.6 as a tested version in Travis CI.

Additionally remove the constraint on patch versions in the Travis
config, so that we'll use the latest patch version available for each
release branch.

* Add Prometheus metrics

Augment the existing operations with Prometheus metrics in order to
provide observability around the operations that the plugin is
performing.

Introduce a new metrics helper to prevent attempting to register the
same metric more than once in a multi-threaded or multi-instance
context.

* Add compress_batches feature

As per the README updates, this can be used to compress a number of
input records into a single Pub/Sub message, therefore saving on costs.

* Include gocardless branch in Travis config

* Minor README fixups

Clarify that the published bytes value is before compression.

Correct the name of the name of the compression ratio metric.

* publish to rubygems

Co-authored-by: Ben Wheatley <contact@benwh.com>
Co-authored-by: Calvin Aditya Jonathan <calvin.aditya@bukalapak.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
cla: yes release notes: yes ruby
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

4 participants