Permalink
Browse files

Ship the newer flexlink with the installer. Mention that the installe…

…r targets a specific OCaml version in the README file.
  • Loading branch information...
1 parent 7d7d008 commit d80efd43fa6b128ffce00d856fc5f160b8af8710 @protz committed Mar 23, 2012
View
6 README.md
@@ -6,7 +6,9 @@ want to download the installer, see the "website" link near the top of the
page.
The installer now uses the "official" toolchain, namely Mingw64 living in a
-Cygwin environment.
+Cygwin environment. The current version of this installer works with OCaml 4.0;
+if you want to compile an older version of OCaml, you need to switch to and older
+revision.
Requirements
------------
@@ -28,6 +30,8 @@ for another.
* `export FLEXLINKFLAGS="-Lc:/cygwin/usr/i686-w64-mingw32/sys-root/mingw/lib/
-Lc:/cygwin/lib/gcc/i686-w64-mingw32/N.N.N/"` where `N.N.N` is the version
of GCC that ships with your Cygwin setup.
+2. Refresh the files in the `flexdll/` directory of the installer, so that the
+ resulting installer ships the right version of flexdll.
2. Grab a copy of ActiveTCL and install it, leave the default path (`c:\tcl`).
2. Grab a copy of the OCaml sources, and keep the default install path
(`c:\ocamlmgw`), this will make your life easier.
View
BIN flexlink/flexdll_initer_mingw.o
Binary file not shown.
View
BIN flexlink/flexdll_mingw.o
Binary file not shown.
View
BIN flexlink/flexlink.exe
Binary file not shown.

0 comments on commit d80efd4

Please sign in to comment.