Skip to content
ProximaX Catapult Crypto Package written in Dart
Dart Shell
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.travis
example
lib
.travis.yml
CHANGELOG.md
LICENSE
README.md
pubspec.yaml

README.md

Vue logo

ProximaX Sirius Blockchain Catapult Crypto Dart

Official ProximaX Sirius Blockchain Catapult implementation ed26619 encryption modules for Dart.

The ProximaX Sirius Catapult Crypto Dart works as a lightweight Dart library for interacting with the Sirius Blockchain. It provides a complete library set coverage, and supports synchronous and asynchronous requests.

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  xpx_crypto: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:xpx_crypto/xpx_crypto.dart';

Wiki and Examples

Examples are in the examples folder

For more examples, go to our wiki

Contribution

We'd love to get more people involved in the project. Please feel free to raise any issues or PR and we'll review your contribution.

Copyright (c) 2019 ProximaX Limited

You can’t perform that action at this time.