Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

use zlib instead of random gzip module

  • Loading branch information...
commit 40cd05071d108ea4162a30168ae71cfb05a81e26 1 parent 7b1a48a
@paulbaumgart paulbaumgart authored
Showing with 3 additions and 4 deletions.
  1. +2 −2 lib/jsbundle-s3.js
  2. +1 −2  package.json
View
4 lib/jsbundle-s3.js
@@ -6,7 +6,7 @@ var awssum = require('awssum');
var amazon = awssum.load('amazon/amazon');
var Q = require('q');
var S3 = awssum.load('amazon/s3').S3;
-var gzip = require('gzip');
+var zlib = require('zlib');
var exec = require('child_process').exec;
var crypto = require('crypto');
@@ -63,7 +63,7 @@ function createBundle(bundlePath, env, options) {
}
process.stderr.write('gzipping ... ');
- Q.ncall(gzip, null, code)
+ Q.ncall(zlib.gzip, zlib, code)
.then(function(data) {
try {
console.error('done.');
View
3  package.json
@@ -3,7 +3,7 @@
"name": "jsbundle",
"description": "Simple, clean, and automatic bundling of your Node modules and packages for use in the browser.",
"keywords": "browser require bundle module package static-analysis",
- "version": "0.16.2",
+ "version": "0.16.3",
"repository": {
"type": "git",
"url": "git://github.com/proxv/jsbundle.git"
@@ -23,7 +23,6 @@
"optimist": "0.3.x",
"connect": "2.x.x",
"awssum": "0.5.1",
- "gzip": "0.1.0",
"q": "0.8.5"
},
"devDependencies": {
Please sign in to comment.
Something went wrong with that request. Please try again.