Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

version 0.9.7.1 fixed ruby_parser dependency issue (too strict)

  • Loading branch information...
commit 6d51109d8870754fa602915fa223544f65f1e789 1 parent 3247f92
@banister banister authored
Showing with 7 additions and 7 deletions.
  1. +2 −2 Rakefile
  2. +1 −1  lib/pry/version.rb
  3. +4 −4 pry.gemspec
View
4 Rakefile
@@ -20,10 +20,10 @@ def apply_spec_defaults(s)
s.executables = ["pry"]
s.files = `git ls-files`.split("\n")
s.test_files = `git ls-files -- test/*`.split("\n")
- s.add_dependency("ruby_parser","~>2.3.1")
+ s.add_dependency("ruby_parser",">= 2.3.1")
s.add_dependency("coderay","~>0.9.8")
s.add_dependency("slop","~>2.1.0")
- s.add_dependency("method_source","~>0.6.5")
+ s.add_dependency("method_source","~>0.6.7")
s.add_development_dependency("bacon","~>1.1.0")
s.add_development_dependency("open4", "~>1.0.1")
s.add_development_dependency("rake", "~>0.9")
View
2  lib/pry/version.rb
@@ -1,3 +1,3 @@
class Pry
- VERSION = "0.9.7"
+ VERSION = "0.9.7.1"
end
View
8 pry.gemspec
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = "pry"
- s.version = "0.9.7"
+ s.version = "0.9.7.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["John Mair (banisterfiend)"]
@@ -21,7 +21,7 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<ruby_parser>, ["~> 2.3.1"])
+ s.add_runtime_dependency(%q<ruby_parser>, [">= 2.3.1"])
s.add_runtime_dependency(%q<coderay>, ["~> 0.9.8"])
s.add_runtime_dependency(%q<slop>, ["~> 2.1.0"])
s.add_runtime_dependency(%q<method_source>, ["~> 0.6.5"])
@@ -29,7 +29,7 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<open4>, ["~> 1.0.1"])
s.add_development_dependency(%q<rake>, ["~> 0.9"])
else
- s.add_dependency(%q<ruby_parser>, ["~> 2.3.1"])
+ s.add_dependency(%q<ruby_parser>, [">= 2.3.1"])
s.add_dependency(%q<coderay>, ["~> 0.9.8"])
s.add_dependency(%q<slop>, ["~> 2.1.0"])
s.add_dependency(%q<method_source>, ["~> 0.6.5"])
@@ -38,7 +38,7 @@ Gem::Specification.new do |s|
s.add_dependency(%q<rake>, ["~> 0.9"])
end
else
- s.add_dependency(%q<ruby_parser>, ["~> 2.3.1"])
+ s.add_dependency(%q<ruby_parser>, [">= 2.3.1"])
s.add_dependency(%q<coderay>, ["~> 0.9.8"])
s.add_dependency(%q<slop>, ["~> 2.1.0"])
s.add_dependency(%q<method_source>, ["~> 0.6.5"])
Please sign in to comment.
Something went wrong with that request. Please try again.