Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Removing versioned .gemspec, adding generic

  • Loading branch information...
commit f6825439d4f3a85d4f63285f7f6384b3b3668bf0 1 parent 4bba687
David Palm authored
Showing with 46 additions and 47 deletions.
  1. +0 −47 pry-0.9.0pre3.gemspec
  2. +46 −0 pry.gemspec
View
47 pry-0.9.0pre3.gemspec
@@ -1,47 +0,0 @@
-# -*- encoding: utf-8 -*-
-
-Gem::Specification.new do |s|
- s.name = %q{pry}
- s.version = "0.9.0pre3"
-
- s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
- s.authors = ["John Mair (banisterfiend)"]
- s.date = %q{2011-06-09}
- s.default_executable = %q{pry}
- s.description = %q{an IRB alternative and runtime developer console}
- s.email = %q{jrmair@gmail.com}
- s.executables = ["pry"]
- s.files = [".document", ".gemtest", ".gitignore", ".yardopts", "CHANGELOG", "LICENSE", "README.markdown", "Rakefile", "TODO", "bin/pry", "examples/example_basic.rb", "examples/example_command_override.rb", "examples/example_commands.rb", "examples/example_hooks.rb", "examples/example_image_edit.rb", "examples/example_input.rb", "examples/example_input2.rb", "examples/example_output.rb", "examples/example_print.rb", "examples/example_prompt.rb", "examples/helper.rb", "lib/pry.rb", "lib/pry/command_context.rb", "lib/pry/command_processor.rb", "lib/pry/command_set.rb", "lib/pry/commands.rb", "lib/pry/completion.rb", "lib/pry/config.rb", "lib/pry/core_extensions.rb", "lib/pry/custom_completions.rb", "lib/pry/default_commands/basic.rb", "lib/pry/default_commands/context.rb", "lib/pry/default_commands/documentation.rb", "lib/pry/default_commands/easter_eggs.rb", "lib/pry/default_commands/gems.rb", "lib/pry/default_commands/input.rb", "lib/pry/default_commands/introspection.rb", "lib/pry/default_commands/ls.rb", "lib/pry/default_commands/shell.rb", "lib/pry/extended_commands/experimental.rb", "lib/pry/extended_commands/user_command_api.rb", "lib/pry/helpers.rb", "lib/pry/helpers/base_helpers.rb", "lib/pry/helpers/command_helpers.rb", "lib/pry/helpers/text.rb", "lib/pry/history_array.rb", "lib/pry/plugins.rb", "lib/pry/pry_class.rb", "lib/pry/pry_instance.rb", "lib/pry/version.rb", "pry-0.9.0pre3.gemspec", "test/helper.rb", "test/test_command_helpers.rb", "test/test_command_processor.rb", "test/test_command_set.rb", "test/test_default_commands.rb", "test/test_default_commands/test_context.rb", "test/test_default_commands/test_documentation.rb", "test/test_default_commands/test_gems.rb", "test/test_default_commands/test_input.rb", "test/test_default_commands/test_introspection.rb", "test/test_history_array.rb", "test/test_pry.rb", "test/testrc", "wiki/Customizing-pry.md", "wiki/Home.md"]
- s.homepage = %q{http://banisterfiend.wordpress.com}
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.6.2}
- s.summary = %q{an IRB alternative and runtime developer console}
- s.test_files = ["test/helper.rb", "test/test_command_helpers.rb", "test/test_command_processor.rb", "test/test_command_set.rb", "test/test_default_commands.rb", "test/test_default_commands/test_context.rb", "test/test_default_commands/test_documentation.rb", "test/test_default_commands/test_gems.rb", "test/test_default_commands/test_input.rb", "test/test_default_commands/test_introspection.rb", "test/test_history_array.rb", "test/test_pry.rb", "test/testrc"]
-
- if s.respond_to? :specification_version then
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<ruby_parser>, [">= 2.0.5"])
- s.add_runtime_dependency(%q<coderay>, [">= 0.9.8"])
- s.add_runtime_dependency(%q<slop>, ["~> 1.6.0"])
- s.add_runtime_dependency(%q<method_source>, [">= 0.4.0"])
- s.add_development_dependency(%q<bacon>, [">= 1.1.0"])
- s.add_development_dependency(%q<open4>, ["~> 1.0.1"])
- else
- s.add_dependency(%q<ruby_parser>, [">= 2.0.5"])
- s.add_dependency(%q<coderay>, [">= 0.9.8"])
- s.add_dependency(%q<slop>, ["~> 1.6.0"])
- s.add_dependency(%q<method_source>, [">= 0.4.0"])
- s.add_dependency(%q<bacon>, [">= 1.1.0"])
- s.add_dependency(%q<open4>, ["~> 1.0.1"])
- end
- else
- s.add_dependency(%q<ruby_parser>, [">= 2.0.5"])
- s.add_dependency(%q<coderay>, [">= 0.9.8"])
- s.add_dependency(%q<slop>, ["~> 1.6.0"])
- s.add_dependency(%q<method_source>, [">= 0.4.0"])
- s.add_dependency(%q<bacon>, [">= 1.1.0"])
- s.add_dependency(%q<open4>, ["~> 1.0.1"])
- end
-end
View
46 pry.gemspec
@@ -0,0 +1,46 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{pry}
+ s.version = "0.9.0pre3"
+
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
+ s.authors = [%q{John Mair (banisterfiend)}]
+ s.date = %q{2011-06-09}
+ s.description = %q{an IRB alternative and runtime developer console}
+ s.email = %q{jrmair@gmail.com}
+ s.executables = [%q{pry}]
+ s.files = [%q{.document}, %q{.gemtest}, %q{.gitignore}, %q{.yardopts}, %q{CHANGELOG}, %q{LICENSE}, %q{README.markdown}, %q{Rakefile}, %q{TODO}, %q{bin/pry}, %q{examples/example_basic.rb}, %q{examples/example_command_override.rb}, %q{examples/example_commands.rb}, %q{examples/example_hooks.rb}, %q{examples/example_image_edit.rb}, %q{examples/example_input.rb}, %q{examples/example_input2.rb}, %q{examples/example_output.rb}, %q{examples/example_print.rb}, %q{examples/example_prompt.rb}, %q{examples/helper.rb}, %q{lib/pry.rb}, %q{lib/pry/command_context.rb}, %q{lib/pry/command_processor.rb}, %q{lib/pry/command_set.rb}, %q{lib/pry/commands.rb}, %q{lib/pry/completion.rb}, %q{lib/pry/config.rb}, %q{lib/pry/core_extensions.rb}, %q{lib/pry/custom_completions.rb}, %q{lib/pry/default_commands/basic.rb}, %q{lib/pry/default_commands/context.rb}, %q{lib/pry/default_commands/documentation.rb}, %q{lib/pry/default_commands/easter_eggs.rb}, %q{lib/pry/default_commands/gems.rb}, %q{lib/pry/default_commands/input.rb}, %q{lib/pry/default_commands/introspection.rb}, %q{lib/pry/default_commands/ls.rb}, %q{lib/pry/default_commands/shell.rb}, %q{lib/pry/extended_commands/experimental.rb}, %q{lib/pry/extended_commands/user_command_api.rb}, %q{lib/pry/helpers.rb}, %q{lib/pry/helpers/base_helpers.rb}, %q{lib/pry/helpers/command_helpers.rb}, %q{lib/pry/helpers/text.rb}, %q{lib/pry/history_array.rb}, %q{lib/pry/plugins.rb}, %q{lib/pry/pry_class.rb}, %q{lib/pry/pry_instance.rb}, %q{lib/pry/version.rb}, %q{pry-0.9.0pre3.gemspec}, %q{test/helper.rb}, %q{test/test_command_helpers.rb}, %q{test/test_command_processor.rb}, %q{test/test_command_set.rb}, %q{test/test_default_commands.rb}, %q{test/test_default_commands/test_context.rb}, %q{test/test_default_commands/test_documentation.rb}, %q{test/test_default_commands/test_gems.rb}, %q{test/test_default_commands/test_input.rb}, %q{test/test_default_commands/test_introspection.rb}, %q{test/test_history_array.rb}, %q{test/test_pry.rb}, %q{test/testrc}, %q{wiki/Customizing-pry.md}, %q{wiki/Home.md}]
+ s.homepage = %q{http://banisterfiend.wordpress.com}
+ s.require_paths = [%q{lib}]
+ s.rubygems_version = %q{1.8.4}
+ s.summary = %q{an IRB alternative and runtime developer console}
+ s.test_files = [%q{test/helper.rb}, %q{test/test_command_helpers.rb}, %q{test/test_command_processor.rb}, %q{test/test_command_set.rb}, %q{test/test_default_commands.rb}, %q{test/test_default_commands/test_context.rb}, %q{test/test_default_commands/test_documentation.rb}, %q{test/test_default_commands/test_gems.rb}, %q{test/test_default_commands/test_input.rb}, %q{test/test_default_commands/test_introspection.rb}, %q{test/test_history_array.rb}, %q{test/test_pry.rb}, %q{test/testrc}]
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<ruby_parser>, [">= 2.0.5"])
+ s.add_runtime_dependency(%q<coderay>, [">= 0.9.8"])
+ s.add_runtime_dependency(%q<slop>, ["~> 1.6.0"])
+ s.add_runtime_dependency(%q<method_source>, [">= 0.4.0"])
+ s.add_development_dependency(%q<bacon>, [">= 1.1.0"])
+ s.add_development_dependency(%q<open4>, ["~> 1.0.1"])
+ else
+ s.add_dependency(%q<ruby_parser>, [">= 2.0.5"])
+ s.add_dependency(%q<coderay>, [">= 0.9.8"])
+ s.add_dependency(%q<slop>, ["~> 1.6.0"])
+ s.add_dependency(%q<method_source>, [">= 0.4.0"])
+ s.add_dependency(%q<bacon>, [">= 1.1.0"])
+ s.add_dependency(%q<open4>, ["~> 1.0.1"])
+ end
+ else
+ s.add_dependency(%q<ruby_parser>, [">= 2.0.5"])
+ s.add_dependency(%q<coderay>, [">= 0.9.8"])
+ s.add_dependency(%q<slop>, ["~> 1.6.0"])
+ s.add_dependency(%q<method_source>, [">= 0.4.0"])
+ s.add_dependency(%q<bacon>, [">= 1.1.0"])
+ s.add_dependency(%q<open4>, ["~> 1.0.1"])
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.