Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update to slop 3.3.1

  • Loading branch information...
commit f9ec9c08bf055fa26946aae3cd7569a04a4fc3e8 1 parent 03b047e
@ConradIrwin ConradIrwin authored
Showing with 12 additions and 12 deletions.
  1. +1 −1  Rakefile
  2. +5 −5 pry.gemspec
  3. +6 −6 test/test_default_commands/test_ls.rb
View
2  Rakefile
@@ -20,7 +20,7 @@ def apply_spec_defaults(s)
s.files = `git ls-files`.split("\n")
s.test_files = `git ls-files -- test/*`.split("\n")
s.add_dependency('coderay', '~> 1.0.5')
- s.add_dependency('slop', ['~> 3.3.0'])
+ s.add_dependency('slop', ['~> 3.3.1'])
s.add_dependency('method_source','~> 0.7.1')
s.add_development_dependency('bacon', '~> 1.1')
s.add_development_dependency('open4', '~> 1.3')
View
10 pry.gemspec
@@ -6,14 +6,14 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["John Mair (banisterfiend)", "Conrad Irwin"]
- s.date = "2012-05-30"
+ s.date = "2012-05-31"
s.description = "An IRB alternative and runtime developer console"
s.email = ["jrmair@gmail.com", "conrad.irwin@gmail.com"]
s.executables = ["pry"]
s.files = [".document", ".gemtest", ".gitignore", ".travis.yml", ".yardopts", "CHANGELOG", "CONTRIBUTORS", "Gemfile", "LICENSE", "README.markdown", "Rakefile", "TODO", "bin/pry", "examples/example_basic.rb", "examples/example_command_override.rb", "examples/example_commands.rb", "examples/example_hooks.rb", "examples/example_image_edit.rb", "examples/example_input.rb", "examples/example_input2.rb", "examples/example_output.rb", "examples/example_print.rb", "examples/example_prompt.rb", "examples/helper.rb", "lib/pry.rb", "lib/pry/cli.rb", "lib/pry/code.rb", "lib/pry/command.rb", "lib/pry/command_set.rb", "lib/pry/commands.rb", "lib/pry/completion.rb", "lib/pry/config.rb", "lib/pry/core_extensions.rb", "lib/pry/custom_completions.rb", "lib/pry/default_commands/cd.rb", "lib/pry/default_commands/commands.rb", "lib/pry/default_commands/context.rb", "lib/pry/default_commands/easter_eggs.rb", "lib/pry/default_commands/editing.rb", "lib/pry/default_commands/find_method.rb", "lib/pry/default_commands/gems.rb", "lib/pry/default_commands/help.rb", "lib/pry/default_commands/hist.rb", "lib/pry/default_commands/input_and_output.rb", "lib/pry/default_commands/introspection.rb", "lib/pry/default_commands/ls.rb", "lib/pry/default_commands/misc.rb", "lib/pry/default_commands/navigating_pry.rb", "lib/pry/extended_commands/experimental.rb", "lib/pry/helpers.rb", "lib/pry/helpers/base_helpers.rb", "lib/pry/helpers/command_helpers.rb", "lib/pry/helpers/documentation_helpers.rb", "lib/pry/helpers/options_helpers.rb", "lib/pry/helpers/text.rb", "lib/pry/history.rb", "lib/pry/history_array.rb", "lib/pry/hooks.rb", "lib/pry/indent.rb", "lib/pry/method.rb", "lib/pry/plugins.rb", "lib/pry/pry_class.rb", "lib/pry/pry_instance.rb", "lib/pry/rbx_method.rb", "lib/pry/rbx_path.rb", "lib/pry/version.rb", "lib/pry/wrapped_module.rb", "man/pry.1", "man/pry.1.html", "man/pry.1.ronn", "pry.gemspec", "test/helper.rb", "test/test_cli.rb", "test/test_code.rb", "test/test_command.rb", "test/test_command_helpers.rb", "test/test_command_integration.rb", "test/test_command_set.rb", "test/test_completion.rb", "test/test_default_commands/test_cd.rb", "test/test_default_commands/test_context.rb", "test/test_default_commands/test_documentation.rb", "test/test_default_commands/test_find_method.rb", "test/test_default_commands/test_gems.rb", "test/test_default_commands/test_help.rb", "test/test_default_commands/test_input.rb", "test/test_default_commands/test_introspection.rb", "test/test_default_commands/test_ls.rb", "test/test_default_commands/test_shell.rb", "test/test_default_commands/test_show_source.rb", "test/test_exception_whitelist.rb", "test/test_history_array.rb", "test/test_hooks.rb", "test/test_indent.rb", "test/test_input_stack.rb", "test/test_method.rb", "test/test_pry.rb", "test/test_pry_defaults.rb", "test/test_pry_history.rb", "test/test_pry_output.rb", "test/test_sticky_locals.rb", "test/test_syntax_checking.rb", "test/test_wrapped_module.rb", "test/testrc", "test/testrcbad", "wiki/Customizing-pry.md", "wiki/Home.md"]
s.homepage = "http://pry.github.com"
s.require_paths = ["lib"]
- s.rubygems_version = "1.8.23"
+ s.rubygems_version = "1.8.24"
s.summary = "An IRB alternative and runtime developer console"
s.test_files = ["test/helper.rb", "test/test_cli.rb", "test/test_code.rb", "test/test_command.rb", "test/test_command_helpers.rb", "test/test_command_integration.rb", "test/test_command_set.rb", "test/test_completion.rb", "test/test_default_commands/test_cd.rb", "test/test_default_commands/test_context.rb", "test/test_default_commands/test_documentation.rb", "test/test_default_commands/test_find_method.rb", "test/test_default_commands/test_gems.rb", "test/test_default_commands/test_help.rb", "test/test_default_commands/test_input.rb", "test/test_default_commands/test_introspection.rb", "test/test_default_commands/test_ls.rb", "test/test_default_commands/test_shell.rb", "test/test_default_commands/test_show_source.rb", "test/test_exception_whitelist.rb", "test/test_history_array.rb", "test/test_hooks.rb", "test/test_indent.rb", "test/test_input_stack.rb", "test/test_method.rb", "test/test_pry.rb", "test/test_pry_defaults.rb", "test/test_pry_history.rb", "test/test_pry_output.rb", "test/test_sticky_locals.rb", "test/test_syntax_checking.rb", "test/test_wrapped_module.rb", "test/testrc", "test/testrcbad"]
@@ -22,14 +22,14 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<coderay>, ["~> 1.0.5"])
- s.add_runtime_dependency(%q<slop>, ["~> 3.3.0"])
+ s.add_runtime_dependency(%q<slop>, ["~> 3.3.1"])
s.add_runtime_dependency(%q<method_source>, ["~> 0.7.1"])
s.add_development_dependency(%q<bacon>, ["~> 1.1"])
s.add_development_dependency(%q<open4>, ["~> 1.3"])
s.add_development_dependency(%q<rake>, ["~> 0.9"])
else
s.add_dependency(%q<coderay>, ["~> 1.0.5"])
- s.add_dependency(%q<slop>, ["~> 3.3.0"])
+ s.add_dependency(%q<slop>, ["~> 3.3.1"])
s.add_dependency(%q<method_source>, ["~> 0.7.1"])
s.add_dependency(%q<bacon>, ["~> 1.1"])
s.add_dependency(%q<open4>, ["~> 1.3"])
@@ -37,7 +37,7 @@ Gem::Specification.new do |s|
end
else
s.add_dependency(%q<coderay>, ["~> 1.0.5"])
- s.add_dependency(%q<slop>, ["~> 3.3.0"])
+ s.add_dependency(%q<slop>, ["~> 3.3.1"])
s.add_dependency(%q<method_source>, ["~> 0.7.1"])
s.add_dependency(%q<bacon>, ["~> 1.1"])
s.add_dependency(%q<open4>, ["~> 1.3"])
View
12 test/test_default_commands/test_ls.rb
@@ -30,21 +30,21 @@
describe "methods" do
it "should show public methods by default" do
- mock_pry("ls Class.new{ def goo; end }.new").should =~ /goo/
+ mock_pry("ls Class.new{ def goo; end }.new").should =~ /methods: goo/
end
it "should not show protected/private by default" do
- mock_pry("ls -M Class.new{ def goo; end; private :goo }").should.not =~ /goo/
- mock_pry("ls Class.new{ def goo; end; protected :goo }.new").should.not =~ /goo/
+ mock_pry("ls -M Class.new{ def goo; end; private :goo }").should.not =~ /methods: goo/
+ mock_pry("ls Class.new{ def goo; end; protected :goo }.new").should.not =~ /methods: goo/
end
it "should show public methods with -p" do
- mock_pry("ls -p Class.new{ def goo; end }.new").should =~ /goo/
+ mock_pry("ls -p Class.new{ def goo; end }.new").should =~ /methods: goo/
end
it "should show protected/private methods with -p" do
- mock_pry("ls -pM Class.new{ def goo; end; protected :goo }").should =~ /goo/
- mock_pry("ls -p Class.new{ def goo; end; private :goo }.new").should =~ /goo/
+ mock_pry("ls -pM Class.new{ def goo; end; protected :goo }").should =~ /methods: goo/
+ mock_pry("ls -p Class.new{ def goo; end; private :goo }.new").should =~ /methods: goo/
end
it "should work for objects with an overridden method method" do
Please sign in to comment.
Something went wrong with that request. Please try again.