Skip to content

Error: Required Gem: `jist` installed but not found?!. #883

Closed
JoshSmith opened this Issue Mar 13, 2013 · 7 comments

7 participants

@JoshSmith

I run into this error when attempting to use/install jist within pry:

[1] pry(main)> gist

The command 'gist' is unavailable because it requires the following gems to be installed: jist
-
Type `install-command gist` to install the required gems and activate this command.
[2] pry(main)> install-command gist
Attempting to install `gist` command...
Installing `jist` gem...
Error: Required Gem: `jist` installed but not found?!. Aborting command installation.
[3] pry(main)> install-command jist
Attempting to install `jist` command...
Installing `jist` gem...
Error: Required Gem: `jist` installed but not found?!. Aborting command installation.
@JoshSmith

This is narrowed down to within the context of a Rails console. When running pry on its own, the gist command works as intended.

@rking
rking commented Mar 13, 2013
@banister
pry member

or consider adding pry-debundle to your Gemfile. pry-debundle allows requiring of gems outside your Gemfile in Pry

@JoshSmith
@thejoecarroll

I'm having the same problem, without Rails.

@rf- rf- added the documentation label Apr 29, 2014
@bbandini

$ gem which simple_xml
D:/ruby/200/lib/ruby/gems/2.0.0/gems/simple-xml-1.0.0/lib/simple_xml.rb

@ConradIrwin
pry member

The jist gem has been deprecated and replaced by the gist gem.

Let me know if you're still having problems when using the gist gem and latest pry.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.