Permalink
Browse files

Lower mem req in thread test. Disable ERD.

  • Loading branch information...
loriab committed Jun 25, 2018
1 parent ec3b974 commit 9df439c5f15cff6fe2192ee121af8b47df2463fb
Showing with 1 addition and 2 deletions.
  1. +1 −0 CMakeLists.txt
  2. +0 −2 psi4/share/psi4/scripts/test_threading.py
@@ -109,6 +109,7 @@ if(ENABLE_gdma OR ENABLE_dkh OR ENABLE_erd OR ENABLE_PCMSolver)
endif()
if(ENABLE_erd)
message(FATAL_ERROR "The Psi4/ERD interface is broken, probably since spring 2017. We'll try to fix it (comment this line to try), but disabling for now.")
message(WARNING "ERD will build, link, and run in Psi4 just fine. However, it has not been hooked into Psi4 in all roles, notably gradients, LRC DFT energies, and ESP. So upon activating through ``set integral_package erd``, known failures will be caught and halted, but perhaps other types not tested and identified will give *wrong* answers. Consider this your warning.")
endif()
@@ -134,8 +134,6 @@ def test_plugin_dfmp2(args):
inputdat = """
import %s
memory 2 gb
molecule {
0 1
C 0.0000000 0.0000000 1.0590353

0 comments on commit 9df439c

Please sign in to comment.