New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add support to libpq version query #35

Closed
dvarrazzo opened this Issue Jan 17, 2011 · 2 comments

Comments

Projects
None yet
1 participant
@dvarrazzo
Copy link
Member

dvarrazzo commented Jan 17, 2011

Can be for the version we compiled against and the runtime one since pg 9.1.

@dvarrazzo

This comment has been minimized.

Copy link
Member

dvarrazzo commented Jun 1, 2015

Docs: http://www.postgresql.org/docs/9.1/static/libpq-misc.html#LIBPQ-PQLIBVERSION

we may expose a __libpq_version__ constant to expose the version compiled in and a extensions.libpq_version() function to return the PQlibVersion() value. If the compiled version is < 9.1 this version should raise a NotSupported exception.

@dvarrazzo

This comment has been minimized.

Copy link
Member

dvarrazzo commented Jun 3, 2015

Merged to master.

@dvarrazzo dvarrazzo closed this Jun 3, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment