Skip to content
Browse files

Remove rails module so typo uses rails gem

Use gems instead of plugins
Declare gems in environment to allow auto-install

Signed-off-by: Frédéric de Villamil <frederic@de-villamil.com>
  • Loading branch information...
1 parent 29df2d7 commit 4cfdeaa16c1c2dbde761540e912a3155052380a1 @mvz mvz committed with fdv
Showing with 5 additions and 16 deletions.
  1. +0 −15 .gitmodules
  2. +5 −0 config/environment.rb
  3. +0 −1 vendor/rails
View
15 .gitmodules
@@ -1,15 +0,0 @@
-[submodule "vendor/rails"]
- path = vendor/rails
- url = git://github.com/rails/rails
-[submodule "vendor/actionwebservice"]
- path = vendor/actionwebservice
- url = git://github.com/datanoise/actionwebservice.git
-[submodule "vendor/plugins/rspec"]
- path = vendor/plugins/rspec
- url = git://github.com/dchelimsky/rspec.git
-[submodule "vendor/plugins/rspec-rails"]
- path = vendor/plugins/rspec-rails
- url = git://github.com/dchelimsky/rspec-rails.git
-[submodule "vendor/plugins/will_paginate"]
- path = vendor/plugins/will_paginate
- url = git://github.com/mislav/will_paginate.git
View
5 config/environment.rb
@@ -60,6 +60,11 @@ class Rails::Configuration
config.gem 'htmlentities'
config.gem 'json'
+ # Declare needed (github) gems
+ config.gem 'datanoise-actionwebservice', :version => '2.2.2', :lib => 'actionwebservice'
+ config.gem 'mislav-will_paginate', :version => '2.3.6', :lib => 'will_paginate'
+ #config.gem 'rspec-rails', :lib => 'spec/rails', :version => '~> 1.1.11'
+
# Force all environments to use the same logger level
# (by default production uses :info, the others :debug)
# config.log_level = :debug
1 vendor/rails
@@ -1 +0,0 @@
-Subproject commit ff561370739eb809d1d006ea842cd2b1e43f6950

0 comments on commit 4cfdeaa

Please sign in to comment.
Something went wrong with that request. Please try again.