Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Can't get composer to work #138

Closed
dereulenspiegel opened this Issue · 4 comments

4 participants

@dereulenspiegel

I'm running a machine with Windows 7 Professional 64Bit. I installed this plugin in several different eclipse versions but while it mostly performs great I cannot get composer to work. It always complains that there is no composer.json (although there is one) and then tries to install composer and the crashes with this message:
!MESSAGE Error while downloading composer.phar.
Eclipse doesn't crash, but composer isn't installed either. So I cannot install any 3rd party bundels (at least through composer).
Apart from that, thanks for the great plugin.

@pulse00
Owner

@dereulenspiegel sorry for the late reply... which updatesite are you using?

@roberteikermann

Hi, same error here. There are no 'composer' entries under preferences ( under window->preferences). And using composer from the context menu in PHP explorer gives the same error as described above.Since the nightly build have this ' invalid character : in c:', I used the normal stable update site. PHP executable is directly available in the console through home variable

@damiencuvillier

Same here. I'm running Eclipse under debian.
Php command is available in path.
& I get the same error
composer in eclipse

I've used eclipse marketplace (from eclipse repository) to install composer plugin...

Any way to enable composer in eclipse ?

@pulse00
Owner

@dereulenspiegel @roberteikermann @damiencuvillier please reopen this issue if you still have these problems. in the meanwhile the Composer plugin has had a major release with a lot of bugfixes and new features: http://composer.dubture.com

@pulse00 pulse00 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.