Silently fails on Eclipse 3.8.x (3.x.y?) #165

Closed
opatry opened this Issue May 6, 2013 · 4 comments

Projects

None yet

2 participants

@opatry
opatry commented May 6, 2013

On Eclipse 3.8.x (standard Eclipse distribution on Ubuntu), the installation succeed but no wizard available for Symfony (Twig installation seems to be recognized, installed the same way).

Same process works fine on Eclipse 4.2.2.

If no support for Eclipse 3.x, can you define as so in your MANIFEST.MF (version restrictions should be used in general!).

If installation should work on Eclipse 3.x, maybe I can digg a little bit more to provide some extra context information.

@opatry opatry referenced this issue in pulse00/Composer-Eclipse-Plugin May 6, 2013
Closed

Eclipse 3.x installation silently fails #60

@pulse00 pulse00 added a commit that referenced this issue May 7, 2013
@pulse00 refs #165 73fdc34
@pulse00 pulse00 added a commit that referenced this issue May 7, 2013
@pulse00 refs #165 1ce7171
@pulse00 pulse00 added a commit that referenced this issue May 7, 2013
@pulse00 refs #165 4bb0307
@pulse00
Owner
pulse00 commented May 8, 2013

@opatry thanks for pointing it out. The Symfony feature now requires >= 4.2.0 explicitly.

@pulse00 pulse00 closed this May 8, 2013
@opatry
opatry commented May 8, 2013

Thanks, much more clear ;)

For my curiosity, is the dependency to 4.x mandatory? Is it too hard to maintain 3.x and 4.x support? (I assume it is if you do so!)

@pulse00
Owner
pulse00 commented May 8, 2013

@opatry well, there's 2 reasons:

  1. A large portion of my time developing the plugins goes into debugging issues users have with their specific setup, so narrowing down the supported versions is just a pragmatic way of optimising the time i can spend on working on the plugins.
  2. I'd like to move on to using new Eclipse 4 features like dependency injection etc.

If anyone would jump in and help maintaining the 3.x eclipse branch, he/she's be more than welcome ;)

@opatry
opatry commented May 8, 2013

Ok, that's what I thought, more a human resource issue than a technical one ;)
I didn't (yet) explore the 4.x branch features, but I assume there are improvements and understand you want to use them!

Thanks for answering and for the job you've already done on these useful plug-ins.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment