Skip to content
This repository
Newer
Older
100644 46 lines (41 sloc) 5.3 kb
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
1 # -*- encoding: utf-8 -*-
2
3 Gem::Specification.new do |s|
4 s.name = "puma"
f50acd28 »
2012-08-12 Bump to 1.6.1
5 s.version = "1.6.1"
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
6
7 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
8 s.authors = ["Evan Phoenix"]
f50acd28 »
2012-08-12 Bump to 1.6.1
9 s.date = "2012-08-12"
e3128c9b »
2012-03-29 Update Manifest and puma.gemspec
10 s.description = "Puma is a simple, fast, and highly concurrent HTTP 1.1 server for Ruby web applications. It can be used with any application that supports Rack, and is considered the replacement for Webrick and Mongrel. It was designed to be the go-to server for [Rubinius](http://rubini.us), but also works well with JRuby and MRI. Puma is intended for use in both development and production environments.\n\nUnder the hood, Puma processes requests using a C-optimized Ragel extension (inherited from Mongrel) that provides fast, accurate HTTP 1.1 protocol parsing in a portable way. Puma then serves the request in a thread from an internal thread pool (which you can control). This allows Puma to provide real concurrency for your web application!\n\nWith Rubinius 2.0, Puma will utilize all cores on your CPU with real threads, meaning you won't have to spawn multiple processes to increase throughput. You can expect to see a similar benefit from JRuby.\n\nOn MRI, there is a Global Interpreter Lock (GIL) that ensures only one thread can be run at a time. But if you're doing a lot of blocking IO (such as HTTP calls to external APIs like Twitter), Puma still improves MRI's throughput by allowing blocking IO to be run concurrently (EventMachine-based servers such as Thin turn off this ability, requiring you to use special libraries). Your mileage may vary. In order to get the best throughput, it is highly recommended that you use a Ruby implementation with real threads like [Rubinius](http://rubini.us) or [JRuby](http://jruby.org)."
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
11 s.email = ["evan@phx.io"]
33176407 »
2011-12-05 Bump to 0.9.0
12 s.executables = ["puma", "pumactl"]
5bacdf43 »
2011-10-13 fix gemspec and manifest, so gem actually installs
13 s.extensions = ["ext/puma_http11/extconf.rb"]
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
14 s.extra_rdoc_files = ["History.txt", "Manifest.txt"]
f50acd28 »
2012-08-12 Bump to 1.6.1
15 s.files = ["COPYING", "Gemfile", "Gemfile.lock", "History.txt", "LICENSE", "Manifest.txt", "README.md", "Rakefile", "TODO", "bin/puma", "bin/pumactl", "examples/CA/cacert.pem", "examples/CA/newcerts/cert_1.pem", "examples/CA/newcerts/cert_2.pem", "examples/CA/private/cakeypair.pem", "examples/CA/serial", "examples/config.rb", "examples/puma/cert_puma.pem", "examples/puma/csr_puma.pem", "examples/puma/puma_keypair.pem", "examples/qc_config.rb", "ext/puma_http11/PumaHttp11Service.java", "ext/puma_http11/ext_help.h", "ext/puma_http11/extconf.rb", "ext/puma_http11/http11_parser.c", "ext/puma_http11/http11_parser.h", "ext/puma_http11/http11_parser.java.rl", "ext/puma_http11/http11_parser.rl", "ext/puma_http11/http11_parser_common.rl", "ext/puma_http11/org/jruby/puma/Http11.java", "ext/puma_http11/org/jruby/puma/Http11Parser.java", "ext/puma_http11/puma_http11.c", "lib/puma.rb", "lib/puma/app/status.rb", "lib/puma/cli.rb", "lib/puma/client.rb", "lib/puma/compat.rb", "lib/puma/configuration.rb", "lib/puma/const.rb", "lib/puma/control_cli.rb", "lib/puma/detect.rb", "lib/puma/events.rb", "lib/puma/jruby_restart.rb", "lib/puma/null_io.rb", "lib/puma/rack_patch.rb", "lib/puma/reactor.rb", "lib/puma/server.rb", "lib/puma/thread_pool.rb", "lib/rack/handler/puma.rb", "puma.gemspec", "test/ab_rs.rb", "test/config/app.rb", "test/hello-post.ru", "test/hello.ru", "test/lobster.ru", "test/mime.yaml", "test/slow.ru", "test/test_app_status.rb", "test/test_cli.rb", "test/test_config.rb", "test/test_http10.rb", "test/test_http11.rb", "test/test_integration.rb", "test/test_null_io.rb", "test/test_persistent.rb", "test/test_puma_server.rb", "test/test_rack_handler.rb", "test/test_rack_server.rb", "test/test_thread_pool.rb", "test/test_unix_socket.rb", "test/test_ws.rb", "test/testhelp.rb", "tools/trickletest.rb"]
6767859c »
2012-04-30 Fix homepage url in gemspec
16 s.homepage = "http://puma.io"
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
17 s.rdoc_options = ["--main", "README.md"]
18 s.require_paths = ["lib"]
717b1456 »
2012-01-08 Updated gemspec to reflect changes
19 s.required_ruby_version = Gem::Requirement.new(">= 1.8.7")
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
20 s.rubyforge_project = "puma"
f50acd28 »
2012-08-12 Bump to 1.6.1
21 s.rubygems_version = "1.8.24"
717b1456 »
2012-01-08 Updated gemspec to reflect changes
22 s.summary = "Puma is a simple, fast, and highly concurrent HTTP 1.1 server for Ruby web applications"
7af141b9 »
2012-05-08 Bump to 1.3.0
23 s.test_files = ["test/test_app_status.rb", "test/test_cli.rb", "test/test_config.rb", "test/test_http10.rb", "test/test_http11.rb", "test/test_integration.rb", "test/test_null_io.rb", "test/test_persistent.rb", "test/test_puma_server.rb", "test/test_rack_handler.rb", "test/test_rack_server.rb", "test/test_thread_pool.rb", "test/test_unix_socket.rb", "test/test_ws.rb"]
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
24
25 if s.respond_to? :specification_version then
26 s.specification_version = 3
27
28 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
e3128c9b »
2012-03-29 Update Manifest and puma.gemspec
29 s.add_runtime_dependency(%q<rack>, ["~> 1.2"])
7af141b9 »
2012-05-08 Bump to 1.3.0
30 s.add_development_dependency(%q<rdoc>, ["~> 3.10"])
28489307 »
2012-05-15 Bump to 1.3.1
31 s.add_development_dependency(%q<rake-compiler>, ["~> 0.8.0"])
32 s.add_development_dependency(%q<hoe>, ["~> 3.0"])
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
33 else
e3128c9b »
2012-03-29 Update Manifest and puma.gemspec
34 s.add_dependency(%q<rack>, ["~> 1.2"])
7af141b9 »
2012-05-08 Bump to 1.3.0
35 s.add_dependency(%q<rdoc>, ["~> 3.10"])
28489307 »
2012-05-15 Bump to 1.3.1
36 s.add_dependency(%q<rake-compiler>, ["~> 0.8.0"])
37 s.add_dependency(%q<hoe>, ["~> 3.0"])
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
38 end
39 else
e3128c9b »
2012-03-29 Update Manifest and puma.gemspec
40 s.add_dependency(%q<rack>, ["~> 1.2"])
7af141b9 »
2012-05-08 Bump to 1.3.0
41 s.add_dependency(%q<rdoc>, ["~> 3.10"])
28489307 »
2012-05-15 Bump to 1.3.1
42 s.add_dependency(%q<rake-compiler>, ["~> 0.8.0"])
43 s.add_dependency(%q<hoe>, ["~> 3.0"])
78df4aa2 »
2011-10-07 Add gemspec for bundler usage
44 end
45 end
Something went wrong with that request. Please try again.