New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Obsolete Node 0.10/0.12 support #1234

Closed
strugee opened this Issue Nov 8, 2016 · 2 comments

Comments

Projects
None yet
1 participant
@strugee
Member

strugee commented Nov 8, 2016

Things that would be nice to do when we no longer have to support Node 0.10 and 0.12:

  • Rip out the sanitize-html XSS scrubber
  • Remove the deprecation warning in bin/pump
  • Use octal literals in lib/pumpclient.js so we can get rid of the stupid "octal" module :/
  • ES6? (Promises? await/async?)

@strugee strugee added the semver-major label Nov 8, 2016

@strugee strugee added this to the Maybe later milestone Nov 8, 2016

@strugee

This comment has been minimized.

Show comment
Hide comment
@strugee

strugee Mar 14, 2017

Member

Add to the list: upgrade Zombie

Member

strugee commented Mar 14, 2017

Add to the list: upgrade Zombie

@strugee strugee modified the milestones: Near future, Maybe later Jun 16, 2017

strugee added a commit that referenced this issue Jun 29, 2017

strugee added a commit that referenced this issue Jun 29, 2017

strugee added a commit that referenced this issue Jun 29, 2017

strugee added a commit that referenced this issue Jun 29, 2017

Rip out the sanitize-html scrubber
This was only there because (our current version of) `jsdom` requires
Node 4+.

Ref #1234

strugee added a commit that referenced this issue Jun 29, 2017

strugee added a commit that referenced this issue Jun 29, 2017

@strugee

This comment has been minimized.

Show comment
Hide comment
@strugee

strugee Jun 29, 2017

Member

Zombie 5.x is about to land on master; closing as I'll file a followup issue for ES6 stuff

Member

strugee commented Jun 29, 2017

Zombie 5.x is about to land on master; closing as I'll file a followup issue for ES6 stuff

@strugee strugee closed this in 0900c2e Jun 29, 2017

vxcamiloxv added a commit to vxcamiloxv/pump.io that referenced this issue Jul 3, 2017

vxcamiloxv added a commit to vxcamiloxv/pump.io that referenced this issue Jul 3, 2017

vxcamiloxv added a commit to vxcamiloxv/pump.io that referenced this issue Jul 3, 2017

vxcamiloxv added a commit to vxcamiloxv/pump.io that referenced this issue Jul 3, 2017

Rip out the sanitize-html scrubber
This was only there because (our current version of) `jsdom` requires
Node 4+.

Ref #1234

vxcamiloxv added a commit to vxcamiloxv/pump.io that referenced this issue Jul 3, 2017

vxcamiloxv added a commit to vxcamiloxv/pump.io that referenced this issue Jul 3, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment