Skip to content

Shortcode based export is broken #73

Closed
basus opened this Issue Jan 6, 2012 · 6 comments

3 participants

@basus
basus commented Jan 6, 2012

Exporting a file with multiple source blocks using the WordPress short codes is broken. The result is very garbled with the source code blocks appearing in the wrong places and some of the blocks passing through as the default Orgmode generated HTML. The export without the short codes works fine. Here is an example of both an Org source file and the HTML cooed out the WordPress editor. Hope that helps. I'm using the latest org-mode and the latest org2blog. The Org-mode HTML export seems to be fine.

@punchagan
Owner
@punchagan
Owner

Unfortunately, I'm unable to reproduce it with the latest version of org-mode and GNU Emacs 23.2.1.

@basus
basus commented Jan 9, 2012

Hmm... I'll do some digging and see if there's something wrong on my end.

@alandmoore

I'm having this exact issue; using emacs 24.1 with org-mode nightly snapshots installed through the package manager. I've been writing a blog post on different markup languages, and it seems that if I include code that looks too much like org-mode markup, it messes up.

I can render to HTML with no problems, and if I turn off shortcodes it works fine (except that it doesn't work with my wordpress syntax-highlighter, so I don't want to use pre blocks).

@punchagan
Owner

@alandmoore Can you give me some sample post to reproduce this?

@punchagan
Owner

Closing as stale. Please reopen if this is still broken on org-8-experimental branch.

@punchagan punchagan closed this Sep 14, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.