support version requirements for gem downloading #59

Closed
daniel-pittman opened this Issue Feb 11, 2013 · 0 comments

1 participant

@daniel-pittman

We need to wire up the version specification feature in gem mirroring, so that we can ensure that specific versions of gems are installed:

  • security issues require a minimum version
  • API compatibility issues require a specific maximum / exact version
@daniel-pittman daniel-pittman added a commit that closed this issue Feb 12, 2013
@daniel-pittman daniel-pittman Allow reading gem list from a file during mirroring
This extends the gem mirroring script to support reading from a file, as well
as the command line, to find out which set of gems to mirror.

This allows an extended input format in the file, where we specify version
constraints, which resolves #59, a need to specify version constraints.
Now we have a clean mechanism for specifying them.

Signed-off-by: Daniel Pittman <daniel@rimspace.net>
4ba16dd
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment