Modified gem controller to support new gem.list file format (Fixes #61) #62

Merged
merged 1 commit into from Feb 15, 2013

2 participants

@tjmcs

Made a small change to the gem controller so that the warnings that resulted from the merge of pull request #60 (which modified the gem.list file so that it might include fields on each line that indicate version limits for each gem) no longer occur. The gem controller now takes the first field from each line as the gem name and ignores any extra fields that may appear in the gem.list file after that gem name. This restores the previous behavior (even in cases where version limits are included for some gems in the list) and prevents the controller from attempting to install gems with names like ">=" and "1.7.7" (which resulted in warnings being thrown during the boot process)

Tom McSweeney modified gem controller to parse new format for gem.list file correctly
(it now takes the first field from each line as the gem name and ignores
any extra fields that may appear in the gem.list file after that gem name)
45845a1
@daniel-pittman daniel-pittman merged commit 6d88420 into puppetlabs:master Feb 15, 2013
@tjmcs tjmcs deleted the tjmcs:tb/fix-gem-list-parse-error branch Feb 16, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment