(#366) Broken dependency on `which` in Debian packaging #367

Merged
merged 1 commit into from Jan 22, 2013

1 participant

@daniel-pittman

The Debian packaging indicates a dependency on the package which, which does
not exist. The correct dependency is on the package debianutils which includes
the which(1) command.

This updates the dependency in the obvious way, fixing the problem, and
closing #366 along the way.

Signed-off-by: Daniel Pittman daniel@rimspace.net

@daniel-pittman daniel-pittman (#366) Broken dependency on `which` in Debian packaging
The Debian packaging indicates a dependency on the package which, which does
not exist. The correct dependency is on the package debianutils which includes
the which(1) command - except that is an "essential" package, so we shouldn't
depend on it, we should just assume it is present.

This drops the dependency in the obvious way, fixing the problem, and
closing #366 along the way.

Signed-off-by: Daniel Pittman <daniel@rimspace.net>
c34c68d
@daniel-pittman daniel-pittman merged commit 1af6f90 into puppetlabs:master Jan 22, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment