Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Replace Glide with Dep and vendor deps

  • Loading branch information...
johnmccabe committed May 23, 2018
1 parent fee1ec4 commit ef4af3b03bf71e54663f921bf943dd288d7a0d9a
Showing 907 changed files with 230,320 additions and 187 deletions.

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
@@ -0,0 +1,42 @@
# Gopkg.toml example
#
# Refer to https://golang.github.io/dep/docs/Gopkg.toml.html
# for detailed Gopkg.toml documentation.
#
# required = ["github.com/user/thing/cmd/thing"]
# ignored = ["github.com/user/project/pkgX", "bitbucket.org/user/project/pkgA/pkgY"]
#
# [[constraint]]
# name = "github.com/user/project"
# version = "1.0.0"
#
# [[constraint]]
# name = "github.com/user/project2"
# branch = "dev"
# source = "github.com/myfork/project2"
#
# [[override]]
# name = "github.com/x/y"
# version = "2.4.0"
#
# [prune]
# non-go = false
# go-tests = true
# unused-packages = true


[[constraint]]
name = "github.com/satori/go.uuid"
version = "1.1.0"

[[constraint]]
name = "github.com/shirou/gopsutil"
version = "2.17.10"

[[constraint]]
name = "github.com/spf13/cobra"
version = "0.0.1"

[prune]
go-tests = true
unused-packages = true
@@ -22,16 +22,8 @@ GOOS ?= linux

build: bin/lumogon

glide.lock: glide.yaml $(GOPATH)/bin/glide$(suffix)
glide update
@touch $@

vendor: glide.lock
glide install
@touch $@

test: lint vet
go test -v -cover `glide novendor` -ldflags '$(TESTLDFLAGS)'
go test -v -cover ./... -ldflags '$(TESTLDFLAGS)'

watch: bootstrap
goconvey
@@ -54,19 +46,16 @@ todo:
grep -rnw "TODO" .

lint: bootstrap $(GOPATH)/src/github.com/golang/lint/golint
golint `glide novendor`
golint ./...

vet: bootstrap
go vet `glide novendor`
go vet ./...

licenses: $(GOPATH)/bin/licenses
@licenses $(PACKAGE_NAME) | grep $(PACKAGE_NAME)/vendor

all: clean vendor test build image puppet-module

$(GOPATH)/bin/glide:
go get -u github.com/Masterminds/glide

$(GOPATH)/src/github.com/golang/lint/golint:
go get -u github.com/golang/lint/golint

@@ -76,7 +65,7 @@ $(GOPATH)/bin/licenses:
$(GOPATH)/bin/goconvey:
go get -u github.com/smartystreets/goconvey

bootstrap: $(GOPATH)/bin/glide $(GOPATH)/src/github.com/golang/lint/golint $(GOPATH)/bin/licenses $(GOPATH)/bin/goconvey
bootstrap: $(GOPATH)/src/github.com/golang/lint/golint $(GOPATH)/bin/licenses $(GOPATH)/bin/goconvey

puppet-module:
cd contrib/puppetlabs-lumogon; make all
Oops, something went wrong.

0 comments on commit ef4af3b

Please sign in to comment.
You can’t perform that action at this time.