Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Improve Ruby 1.9 compatibility:

 - Make ftools require optional, so it works correctly under Ruby 1.9
 - Make case statements 1.9 compatible
  • Loading branch information...
commit c0889040e2619ece93b836139e46a4d2f173749a 1 parent fefe7c8
@auxesis auxesis authored jamtur01 committed
Showing with 6 additions and 4 deletions.
  1. +1 −1  Rakefile
  2. +5 −3 tasks/rake/git_workflow.rake
View
2  Rakefile
@@ -6,7 +6,7 @@ require 'rubygems'
require 'rake'
require 'rake/gempackagetask'
require 'fileutils'
-require 'ftools'
+require 'ftools' if RUBY_VERSION =~ /^1.8/
# Return filename matching an array of glob patterns, minus any ephemeral files
# that don't belong in the gem.
View
8 tasks/rake/git_workflow.rake
@@ -6,9 +6,11 @@ def find_start(start)
# This is a case statement, as we might want to map certain
# git tags to starting points that are not currently in git.
case start
- when nil?:
- when @next_release: return "master"
- else return start
+ when nil?
+ when @next_release
+ return "master"
+ else
+ return start
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.