Permalink
Browse files

Merge branch '2.7.x' into 3.0.x

* 2.7.x:
  (maint) Add Travis CI support to active branches

Conflicts:
	.gitignore
	Gemfile
	puppet.gemspec
  • Loading branch information...
2 parents 939abc7 + f8a8496 commit 96cd43638d232271472c589a5fd72eecef735335 @jeffmccune jeffmccune committed Jan 7, 2013
Showing with 63 additions and 5 deletions.
  1. +4 −0 .gitignore
  2. +11 −0 .travis.yml
  3. +9 −5 Gemfile
  4. +39 −0 puppet.gemspec
View
@@ -11,4 +11,8 @@ doc
# Now that there is a gemfile, RVM ignores rvmrc in parent directories, so a local one is required
# to work around that. Which we don't want committed, so we can ignore it here.
/.rvmrc
+.bundle/
+ext/packaging/
+pkg/
+vendor/
Gemfile.lock
View
@@ -0,0 +1,11 @@
+language: ruby
+bundler_args: --without development
+script: "bundle exec rake spec SPEC_OPTS='--color --format documentation'"
+notifications:
+ email: false
+rvm:
+ - 1.8.7
+ - 1.9.3
+matrix:
+ allow_failures:
+ - rvm: 1.9.3
View
14 Gemfile
@@ -1,13 +1,10 @@
source :rubygems
-# This is a fake version just to make bundler happy during development
-FAKE_VERSION = '9999.0.0'
-
def location_for(place)
if place =~ /^(git:[^#]*)#(.*)/
[{ :git => $1, :branch => $2, :require => false }]
elsif place =~ /^file:\/\/(.*)/
- [FAKE_VERSION, { :path => File.expand_path($1), :require => false }]
+ ['>= 0', { :path => File.expand_path($1), :require => false }]
else
[place, { :require => false }]
end
@@ -18,9 +15,16 @@ group(:development, :test) do
gem "facter", *location_for(ENV['FACTER_LOCATION'] || '~> 1.6')
gem "hiera", *location_for(ENV['HIERA_LOCATION'] || '~> 1.0')
gem "rack", "~> 1.4", :require => false
- gem "rake", "~> 0.9.2", :require => false
+ gem "rake", :require => false
gem "rspec", "~> 2.11.0", :require => false
gem "mocha", "~> 0.10.5", :require => false
+ gem "activerecord", *location_for('~> 3.0.7')
+ gem "couchrest", *location_for('~> 1.0')
+ gem "net-ssh", *location_for('~> 2.1')
+ gem "puppetlabs_spec_helper"
+ gem "sqlite3"
+ gem "stomp"
+ gem "tzinfo"
end
platforms :mswin, :mingw do
View
@@ -0,0 +1,39 @@
+# -*- encoding: utf-8 -*-
+
+require File.expand_path("../lib/puppet/version", __FILE__)
+
+Gem::Specification.new do |s|
+ s.name = "puppet"
+ version = Puppet.version
+ if mdata = version.match(/(\d+\.\d+\.\d+)/)
+ s.version = mdata[1]
+ else
+ s.version = version
+ end
+
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Puppet Labs"]
+ s.date = "2012-08-17"
+ s.description = "Puppet, an automated configuration management tool"
+ s.email = "puppet@puppetlabs.com"
+ s.executables = ["puppet"]
+ s.files = ["bin/puppet"]
+ s.homepage = "http://puppetlabs.com"
+ s.rdoc_options = ["--title", "Puppet - Configuration Management", "--main", "README", "--line-numbers"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = "puppet"
+ s.rubygems_version = "1.8.24"
+ s.summary = "Puppet, an automated configuration management tool"
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<facter>, ["~> 1.5"])
+ else
+ s.add_dependency(%q<facter>, ["~> 1.5"])
+ end
+ else
+ s.add_dependency(%q<facter>, ["~> 1.5"])
+ end
+end

0 comments on commit 96cd436

Please sign in to comment.