Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Relax gem dependencies on Facter and Hiera #1372

Merged
merged 1 commit into from Jan 7, 2013

Conversation

Projects
None yet
2 participants
Contributor

jeffmccune commented Jan 6, 2013

Without this patch applied an older version of Hiera is automatically
installed as a dependency installing Puppet. This is a problem because
there are important bug fixes happening in later minor versions of
Hiera. The same is true of Facter. The cause of the problem is a tight
specification of gem :hiera, "~> 1.0.0" which means "greater than
1.0.0 but less then 1.1.0". 1.1.2 is the current latest bug fix version
of Hiera.

This patch fixes the problem by relaxing the dependency to "~> 1.0"
which means "greater than 1.0.0 and less than 2.0.0"

@haus haus commented on the diff Jan 6, 2013

ext/project_data.yaml
@@ -15,8 +15,8 @@ gem_executables: 'puppet'
gem_default_executables: 'puppet'
gem_forge_project: 'puppet'
gem_runtime_dependencies:
- facter: '~> 1.6.11'
- hiera: '~> 1.0.0'
+ facter: '~> 1.6'
@haus

haus Jan 6, 2013

Member

The facter dependency can't be less than 1.6.2 because the osfamily fact was introduced in that release and puppet 3.x depends in several places on the osfamily fact.

There also were some ruby 1.9 fixes later in the 1.6 series that allow facter 1.6 and puppet 3.x to play well together on ruby 1.9.

@jeffmccune

jeffmccune Jan 6, 2013

Contributor

Cool, is there something you think this should be changed to? ~> 1.6 seems
to be pretty good since we're well beyond 1.6.2 and 1.6.11 at this point
and we're probably going to release 1.7 at some point.

@haus

haus Jan 7, 2013

Member

~> 1.6 is probably the best we can get for right now. When 1.7 ships it will make for a much cleaner dependency, since there won't be features in any 1.7.x releases.

Relax gem dependencies on Facter and Hiera
Without this patch applied an older version of Hiera is
automatically installed as a dependency installing Puppet.  This is a
problem because there are important bug fixes happening in later minor
versions of Hiera.  The same is true of Facter.  The cause of the
problem is a tight specification of `gem :hiera, "~> 1.0.0"` which means
"greater than 1.0.0 but less then 1.1.0".  1.1.2 is the current latest
bug fix version of Hiera.

This patch fixes the problem by relaxing the dependency to "~> 1.0"
which means "greater than 1.0.0 and less than 2.0.0"

jeffmccune added a commit that referenced this pull request Jan 7, 2013

Merge pull request #1372 from jeffmccune/fix/master/gem_dependencies
Relax gem dependencies on Facter and Hiera

@jeffmccune jeffmccune merged commit bc19ea9 into puppetlabs:master Jan 7, 2013

1 check passed

default The Travis build passed
Details

@jeffmccune jeffmccune deleted the jeffmccune:fix/master/gem_dependencies branch Jan 7, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment