Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

(maint) add upgrading from v3 document to stable branch #1347

Merged
Merged
Changes from all commits
Commits
File filter...
Filter file types
Jump to…
Jump to file or symbol
Failed to load files and symbols.

Always

Just for now

@@ -56,6 +56,7 @@ <h2 id="puppetdb">PuppetDB {{ puppetdb_version }}</h2>
</li>
<li><strong>Query API Version 4 (experimental)</strong>
<ul>
<li><a href="/puppetdb/{{ puppetdb_version }}/api/query/v4/preparing-for-3.0.markdown">Upgrading from Version 3</a></li>
<li><a href="/puppetdb/{{ puppetdb_version }}/api/query/v4/query.html">Query Structure</a></li>
<li><a href="/puppetdb/{{ puppetdb_version }}/api/query/v4/operators.html">Available Operators</a></li>
<li><a href="/puppetdb/{{ puppetdb_version }}/api/query/v4/paging.html">Query Paging</a></li>
@@ -0,0 +1,14 @@
---
title: "PuppetDB 2.3 » API » v4 » Preparing for PuppetDB 3.0"
layout: default
canonical: "/puppetdb/latest/api/query/v4/preparing-for-3.0.html"
---

### Preparing for PuppetDB 3.0

With the upcoming 3.0 major release of PuppetDB, the v2 and v3 query APIs will
be retired and the v4 API will be the only one that remains. Users developing
against PuppetDB's query API are encouraged to refer to the
[upgrading guide in our master branch](https://docs.puppetlabs.com/puppetdb/master/api/query/v4/upgrading-from-v3.html)
to stay up to date on the changes planned. Note that this document is not in
its final state, and will continue to be updated as the release approaches.
ProTip! Use n and p to navigate between commits in a pull request.
You can’t perform that action at this time.