Skip to content
Permalink
Browse files

MODULES-5649 Do not install mod_fastcgi on el7

  • Loading branch information...
tphoney committed Sep 27, 2017
1 parent 82ce45d commit 6c1ed75df6988dee291041c1bc4251f0f9525be9
Showing with 8 additions and 2 deletions.
  1. +3 −1 manifests/mod/fastcgi.pp
  2. +5 −1 manifests/params.pp
@@ -1,6 +1,8 @@
class apache::mod::fastcgi {
include ::apache

if ($::osfamily == 'Redhat' and versioncmp($::operatingsystemrelease, '7.0') >= 0) {
fail('mod_fastcgi is no longer supported on el7 and above.')
}
# Debian specifies it's fastcgi lib path, but RedHat uses the default value
# with no config file
$fastcgi_lib_path = $::apache::params::fastcgi_lib_path
@@ -106,7 +106,11 @@
default => 'mod_authz_ldap',
},
'authnz_pam' => 'mod_authnz_pam',
'fastcgi' => 'mod_fastcgi',
'fastcgi' => $::apache::version::distrelease ? {
'5' => 'mod_fastcgi',
'6' => 'mod_fastcgi',
default => undef,
},
'fcgid' => 'mod_fcgid',
'geoip' => 'mod_geoip',
'intercept_form_submit' => 'mod_intercept_form_submit',

0 comments on commit 6c1ed75

Please sign in to comment.
You can’t perform that action at this time.