Permalink
Browse files

Merge pull request #463 from apenney/fix-oracle

This should help tests on Oracle 6, the lack of epel was breaking the bi...
  • Loading branch information...
2 parents 1454a5b + 820344f commit ac991e8e413caf4e6d17269302f631f9213203aa Ashley Penney committed Feb 24, 2014
Showing with 8 additions and 0 deletions.
  1. +8 −0 spec/spec_helper_acceptance.rb
@@ -29,6 +29,14 @@
if fact('osfamily') == 'RedHat'
version = fact("operatingsystemmajrelease")
shell("yum localinstall -y http://yum.puppetlabs.com/puppetlabs-release-el-#{version}.noarch.rpm")
+ if version == '6'
+ shell("yum localinstall -y http://mirror.pnl.gov/epel/6/i386/epel-release-6-8.noarch.rpm")
+ elsif version == '5'
+ shell("yum localinstall -y http://mirrors.servercentral.net/fedora/epel/5/i386/epel-release-5-4.noarch.rpm")
+ else
+ puts "Sorry, this version is not supported."
+ exit
+ end
end
shell('/bin/touch /etc/puppet/hiera.yaml')

0 comments on commit ac991e8

Please sign in to comment.