Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add compatibility for Amazon Linux 2 #1328

Merged
merged 3 commits into from Nov 3, 2020
Merged

Add compatibility for Amazon Linux 2 #1328

merged 3 commits into from Nov 3, 2020

Conversation

greno2
Copy link
Contributor

@greno2 greno2 commented Sep 22, 2020

No description provided.

@greno2 greno2 requested a review from a team as a code owner September 22, 2020 15:15
@puppet-community-rangefinder
Copy link

mysql::params is a class

Breaking changes to this file WILL impact these 2 modules (exact match):
Breaking changes to this file MAY impact these 1 modules (near match):

This module is declared in 142 of 575 indexed public Puppetfiles.


These results were generated with Rangefinder, a tool that helps predict the downstream impact of breaking changes to elements used in Puppet modules. You can run this on the command line to get a full report.

Exact matches are those that we can positively identify via namespace and the declaring modules' metadata. Non-namespaced items, such as Puppet 3.x functions, will always be reported as near matches only.

@sanfrancrisko sanfrancrisko changed the title Support for Amazon Linux 2 (based on el7) Add compatibility for Amazon Linux 2 Sep 30, 2020
@pmcmaw
Copy link
Contributor

pmcmaw commented Nov 2, 2020

Hey @greno2,
We are more than happy to merge this PR once Travis runs green, although I would like to make you aware that this is not something we will support. This means we will not be in a position to maintain any support in relation to Amazon Linux 2.

@pmcmaw pmcmaw changed the base branch from master to main November 2, 2020 18:09
@pmcmaw pmcmaw closed this Nov 2, 2020
@pmcmaw pmcmaw reopened this Nov 2, 2020
@puppet-community-rangefinder
Copy link

mysql::params is a class

Breaking changes to this file WILL impact these 2 modules (exact match):
Breaking changes to this file MAY impact these 1 modules (near match):

This module is declared in 142 of 575 indexed public Puppetfiles.


These results were generated with Rangefinder, a tool that helps predict the downstream impact of breaking changes to elements used in Puppet modules. You can run this on the command line to get a full report.

Exact matches are those that we can positively identify via namespace and the declaring modules' metadata. Non-namespaced items, such as Puppet 3.x functions, will always be reported as near matches only.

@pmcmaw pmcmaw self-assigned this Nov 3, 2020
@pmcmaw
Copy link
Contributor

pmcmaw commented Nov 3, 2020

Travis is running green, it just hasn't updated on the UI. Passing build can be found here: https://travis-ci.org/github/puppetlabs/puppetlabs-mysql/builds/740933492

Merging.

As previously stated, please be aware this PR will make the code base compatible with Amazon Linux although Puppet will not be supporting this configuration.

As always, thank you for your PR and your contributions towards our modules.

@pmcmaw pmcmaw added the feature label Nov 3, 2020
@pmcmaw pmcmaw merged commit a043531 into puppetlabs:main Nov 3, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants