fix mocha deprecation warnings #156

Merged
merged 1 commit into from Mar 1, 2013

2 participants

@mattr-

A new clone and bundle with puppetlabs-mysql installs mocha 0.13.2. This version of Mocha has deprecated the use of require 'mocha' and instead recommends using require 'mocha/api' for test frameworks that are not Test::Unit or MiniTest.

This pull request fixes those deprecation warnings.

@mattr-

This is issue 19536 on projects.puppetlabs.com

The travis build only fails for puppet version 2.6.0 (and was failing before submitting this pull request). Hopefully that doesn't block this PR getting merged.

@kbarber kbarber merged commit 8eb71cc into puppetlabs:master Mar 1, 2013

1 check failed

Details default The Travis build failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment