Permalink
Commits on Jun 22, 2017
  1. Release 1.0.0

    hunner committed Jun 22, 2017
  2. Merge pull request #83 from bastelfreak/ArchlinuxSupport

    bmjen committed Jun 22, 2017
    Add support for Arch Linux
  3. Add support for Arch Linux

    mmerfort committed with bastelfreak Jun 17, 2017
    * Add Arch Linux default params
    * Do not install some packages on Arch Linux, they are included in the
      ruby package
    * Add tests for Arch Linux
    * Update the README
  4. Merge pull request #82 from bastelfreak/Puppet4

    bmjen committed Jun 22, 2017
    Puppet4
  5. Do not test incompatible Ruby and Puppet version combos

    mmerfort committed with bastelfreak Jun 21, 2017
    * Remove Ruby 2.0.0
    * Remove Ruby 2.3.1
Commits on Jun 21, 2017
  1. Remove Puppet 3 Support

    mmerfort committed Jun 21, 2017
    * Update README
    * Rework .travis.yml
Commits on Jun 6, 2017
Commits on Mar 7, 2017
Commits on Dec 20, 2016
  1. Merge pull request #74 from tphoney/0_6_0_prep

    HelenCampbell committed Dec 20, 2016
    FM-5793 0.6.0 release prep
  2. FM-5793 0.6.0 release prep

    tphoney committed Dec 20, 2016
Commits on Nov 7, 2016
  1. Merge pull request #73 from ghoneycutt/remove_unused_metadata

    DavidS committed Nov 7, 2016
    Remove unused metadata
  2. Remove unused metadata

    ghoneycutt committed Nov 7, 2016
    Removes PE information from supported versions of Puppet as per David
    Schmitt's request.
  3. Merge pull request #72 from ghoneycutt/ruby231

    tphoney committed Nov 7, 2016
    Support Puppet v4 AIO
Commits on Nov 4, 2016
  1. Support Puppet v4 AIO

    ghoneycutt committed Nov 4, 2016
    This adds support for running under Puppet v4 with Ruby v2.3.1 and
    explicitly tests supported versions.
Commits on Oct 5, 2016
  1. Use community style

    ghoneycutt committed Oct 5, 2016
Commits on Aug 4, 2016
  1. Merge pull request #66 from robertvargason/debian_bundler_package

    tphoney committed Aug 4, 2016
    Fix bundler_package name for ubuntu (provider gem).
  2. Fix testing (#67)

    ghoneycutt committed with tphoney Aug 4, 2016
    * Pin json and json pure gems so testing can continue
    * Ignore puppet-lint check of 140 characters
    Already ignoring 80 character limit and the new limit comes with the new
    version of puppet-lint
    * Fix style with default case, which fails on an unsupported osfamily
    * Style fixes
Commits on Jun 30, 2016
  1. Fix bundler_package name for ubuntu (provider gem).

    robertvargason committed Jun 30, 2016
    Bundler gem is called bundler on all ubuntu versions.
Commits on May 24, 2016
  1. Merge pull request #64 from HelenCampbell/0.5.0Release

    tphoney committed May 24, 2016
    Release Prep 0.5.0
Commits on May 23, 2016
  1. Release Prep 0.5.0

    HelenCampbell committed May 23, 2016
Commits on Apr 11, 2016
  1. Merge pull request #63 from hunner/fix_ruby

    bmjen committed Apr 11, 2016
    (MODULES-1387) Use ruby-bundler on ubuntu < 14.04
Commits on Apr 8, 2016
  1. (MODULES-1387) Use ruby-bundler on ubuntu < 14.04

    hunner committed Apr 8, 2016
    And fix all the other failing tests
  2. Merge pull request #62 from ghoneycutt/patch-1

    hunner committed Apr 8, 2016
    Fix style in examples
  3. Fix style in examples

    ghoneycutt committed Apr 8, 2016
Commits on Nov 19, 2015
  1. Merge pull request #60 from petems/MODULES-2802-fix_multiple_source_i…

    bmjen committed Nov 19, 2015
    …n_gemrc
    
    (MODULES-2802) Fix multiple source in gemrc