Ruby 2.0 compatibility #17

Closed
purcell opened this Issue Nov 10, 2013 · 4 comments

Comments

Projects
None yet
2 participants
@purcell
Owner

purcell commented Nov 10, 2013

There's no iconv in Ruby 2.0, so darcs-to-git fails. Need to make character set conversion work in all common ruby versions.

@spl

This comment has been minimized.

Show comment Hide comment
@spl

spl Nov 12, 2013

Just checked out the repository and ran into this on Mac OS X 10.9 (Mavericks):

$ ./darcs-to-git --help
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- iconv (LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from ./darcs-to-git:32:in `<main>'

$ which ruby
/usr/bin/ruby

$ ruby --version
ruby 2.0.0p247 (2013-06-27 revision 41674) [universal.x86_64-darwin13]

Do you have a fix, or is there a workaround?

spl commented Nov 12, 2013

Just checked out the repository and ran into this on Mac OS X 10.9 (Mavericks):

$ ./darcs-to-git --help
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- iconv (LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
    from ./darcs-to-git:32:in `<main>'

$ which ruby
/usr/bin/ruby

$ ruby --version
ruby 2.0.0p247 (2013-06-27 revision 41674) [universal.x86_64-darwin13]

Do you have a fix, or is there a workaround?

@purcell

This comment has been minimized.

Show comment Hide comment
@purcell

purcell Nov 12, 2013

Owner

Not yet. Just realised this myself 2 days ago, but I'm fortunate enough to have multiple ruby versions installed.

Give me half an hour and I'll see if I can make a quick fix.

Owner

purcell commented Nov 12, 2013

Not yet. Just realised this myself 2 days ago, but I'm fortunate enough to have multiple ruby versions installed.

Give me half an hour and I'll see if I can make a quick fix.

@purcell purcell closed this in b3e88ac Nov 12, 2013

@purcell

This comment has been minimized.

Show comment Hide comment
@purcell

purcell Nov 12, 2013

Owner

There, please give that a whirl.

Owner

purcell commented Nov 12, 2013

There, please give that a whirl.

@spl

This comment has been minimized.

Show comment Hide comment
@spl

spl Nov 12, 2013

Worked for me. Thanks!

spl commented Nov 12, 2013

Worked for me. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment