when I open emacs,it occurs a warning #74

Closed
tolerious opened this Issue Mar 16, 2013 · 3 comments

Projects

None yet

2 participants

@tolerious

Debugger entered--Lisp error: (error "Package emacs-24.1' is unavailable") signal(error ("Packageemacs-24.1' is unavailable"))
error("Package `%s-%s' is unavailable" "emacs" "24.1")
package-compute-transaction((js2-mode simple-httpd skewer-mode) ((emacs (24 1))))
package-compute-transaction((skewer-mode) ((simple-httpd (1 4 0)) (js2-mode (20090723))))
package-install(skewer-mode)
(if (or (assoc package package-archive-contents) no-refresh) (package-install package) (progn (package-refresh-contents) (require-package package min-version t)))
(if (package-installed-p package min-version) t (if (or ... no-refresh) (package-install package) (progn ... ...)))
require-package(skewer-mode)
eval-buffer(#<buffer load<2>> nil "/home/fengxiaolong/.emacs.d/init-javascript.el" nil t) ; Reading at buffer position 3353
load-with-code-conversion("/home/fengxiaolong/.emacs.d/init-javascript.el" "/home/fengxiaolong/.emacs.d/init-javascript.el" nil t)
require(init-javascript)
eval-buffer(#<buffer load> nil "/home/fengxiaolong/.emacs.d/init.el" nil t) ; Reading at buffer position 2106
load-with-code-conversion("/home/fengxiaolong/.emacs.d/init.el" "/home/fengxiaolong/.emacs.d/init.el" t t)
load("/home/fengxiaolong/.emacs.d/init" t t)
#[nil "�\205\264

@purcell
Owner
purcell commented Mar 16, 2013

Hmmm. So you have Emacs 23. I'd strongly suggest upgrading to version 24, which has been the latest stable release for quite a while now.

However, I will also add code to disable the corresponding functionality in Emacs 23, so that this error does not appear.

@purcell purcell closed this in 9a2cb00 Mar 16, 2013
@purcell
Owner
purcell commented Mar 16, 2013

Okay, I committed a workaround. But still, grab Emacs 24 if you can -- it's a big improvement! :-)

@tolerious

ok,thank you very much,I will upgrade to version 24

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment