Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Array doesn't show all the data #901

Open
mariobuoninfante opened this issue Mar 3, 2020 · 4 comments
Open

Array doesn't show all the data #901

mariobuoninfante opened this issue Mar 3, 2020 · 4 comments

Comments

@mariobuoninfante
Copy link

@mariobuoninfante mariobuoninfante commented Mar 3, 2020

MacOS High Sierra 10.13.1
Pd 0.50.2


STEPS

  • open a new patch
  • create an array (Put->Array)
  • set array size to 1027
  • set Draw as: to polygon
  • click OK to confirm
  • set X range end point to 1026
  • set X size to 1027

RESULTS

  • the array doesn't display some points at the end of the graph
  • the data is in there (check list of values in the array properties)

Screen Shot 2020-03-03 at 13 13 11

@umlaeute

This comment has been minimized.

Copy link
Contributor

@umlaeute umlaeute commented Mar 3, 2020

duplicate of #235 ?

@umlaeute umlaeute closed this Mar 3, 2020
@mariobuoninfante

This comment has been minimized.

Copy link
Author

@mariobuoninfante mariobuoninfante commented Mar 3, 2020

@umlaeute
Is this really related to #235?
That seems to be related to the size of the array, while in this case I'm using an array of 1027 points.
Plus, and I should have clarified this, sorry, If I use points instead of polygon it's all fine

@mariobuoninfante

This comment has been minimized.

Copy link
Author

@mariobuoninfante mariobuoninfante commented Mar 3, 2020

repro'd on Ubuntu Studio 16.04 64bit - Pd 0.50.0

here you can see 2 arrays with the same settings, only one is set to Polygon, the other to Points.
The latter shows all the points

pd_array_visualization_issue

@mariobuoninfante

This comment has been minimized.

Copy link
Author

@mariobuoninfante mariobuoninfante commented Mar 3, 2020

when the x size is set to 512 the polygon array from above shows all the values.
The issue seems to be related to the x size parameter.

@umlaeute umlaeute reopened this Mar 4, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.