Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Nokogiri dependency in gem spec should be >= 1.4.1 #4

Open
superdeluxesam opened this Issue Jan 29, 2010 · 0 comments

Comments

Projects
None yet
1 participant

Some of our devs here have had trouble when using version 1.3.3 and 1.4.0 of Nokogiri, we were getting this output:

undefined method at_css' for #<Nokogiri::HTML::Document:0x10cd7e878> /opt/local/lib/ruby/gems/1.8/gems/mail_style-0.1.3/lib/mail_style/inline_styles.rb:89:increate_html_document'
/opt/local/lib/ruby/gems/1.8/gems/mail_style-0.1.3/lib/mail_style/inline_styles.rb:30:in parse_html' /opt/local/lib/ruby/gems/1.8/gems/mail_style-0.1.3/lib/mail_style/inline_styles.rb:20:inwrite_inline_styles'
/opt/local/lib/ruby/gems/1.8/gems/mail_style-0.1.3/lib/mail_style/inline_styles.rb:19:in each' /opt/local/lib/ruby/gems/1.8/gems/mail_style-0.1.3/lib/mail_style/inline_styles.rb:19:inwrite_inline_styles'
/opt/local/lib/ruby/gems/1.8/gems/mail_style-0.1.3/lib/mail_style/inline_styles.rb:11:in `create_mail'

Everything seems fine when we upgraded to Nokogiri 1.4.1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment