New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pypi release requires python 3.6 while repo says 3.5 #127

Closed
irmen opened this Issue Sep 23, 2017 · 6 comments

Comments

Projects
None yet
2 participants
@irmen

irmen commented Sep 23, 2017

Hi, when installing arcade using pip, it fails to run because of a python 3.6 dependency enforced:

>>> import arcade
The Arcade Library requires Python 3.6 or higher.

The code here on github however has a check for 3.5 instead. Any chance to fix the lib on pypi?

@pvcraven pvcraven added the bug label Oct 3, 2017

@pvcraven pvcraven self-assigned this Oct 3, 2017

@pvcraven

This comment has been minimized.

Show comment
Hide comment
@pvcraven

pvcraven Nov 7, 2017

Owner

Where is this github 3.5 check? I'm not sure what you are referring to.

Owner

pvcraven commented Nov 7, 2017

Where is this github 3.5 check? I'm not sure what you are referring to.

@irmen

This comment has been minimized.

Show comment
Hide comment
@irmen

irmen Nov 8, 2017

the code here in the master branch does this check for python 3.5:

https://github.com/pvcraven/arcade/blob/master/arcade/__init__.py#L9

the wheel on pypi (which gets installed via pip) however contains a check against python 3.6 there. Hence the request to upload a new wheel release to pypi with the proper version check

irmen commented Nov 8, 2017

the code here in the master branch does this check for python 3.5:

https://github.com/pvcraven/arcade/blob/master/arcade/__init__.py#L9

the wheel on pypi (which gets installed via pip) however contains a check against python 3.6 there. Hence the request to upload a new wheel release to pypi with the proper version check

@pvcraven

This comment has been minimized.

Show comment
Hide comment
@pvcraven

pvcraven Nov 9, 2017

Owner

Version 1.2 branch says it requires 3.6. Will be fixed in 1.2. Probably leave as-is with 3.5 for the 1.1 branch.

Owner

pvcraven commented Nov 9, 2017

Version 1.2 branch says it requires 3.6. Will be fixed in 1.2. Probably leave as-is with 3.5 for the 1.1 branch.

@pvcraven pvcraven added this to the 1.2.2 milestone Nov 25, 2017

@pvcraven

This comment has been minimized.

Show comment
Hide comment
@pvcraven

pvcraven Dec 2, 2017

Owner

Closed, implemented in 1.2.2 which is now deployed on PyPi.

Owner

pvcraven commented Dec 2, 2017

Closed, implemented in 1.2.2 which is now deployed on PyPi.

@pvcraven pvcraven closed this Dec 2, 2017

@irmen

This comment has been minimized.

Show comment
Hide comment
@irmen

irmen Dec 2, 2017

thanks, however, the documentation on http://arcade.academy/installation.html still says Python 3.5

irmen commented Dec 2, 2017

thanks, however, the documentation on http://arcade.academy/installation.html still says Python 3.5

pvcraven added a commit that referenced this issue Dec 3, 2017

@pvcraven

This comment has been minimized.

Show comment
Hide comment
@pvcraven

pvcraven Dec 3, 2017

Owner

Thanks, missed that.

Docs should be updated tomorrow or whenever once the Amazon cloud syncs.

Owner

pvcraven commented Dec 3, 2017

Thanks, missed that.

Docs should be updated tomorrow or whenever once the Amazon cloud syncs.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment