New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Improve audio support #167

Closed
pvcraven opened this Issue Dec 19, 2017 · 2 comments

Comments

Projects
1 participant
@pvcraven
Owner

pvcraven commented Dec 19, 2017

Bug Report

Actual behavior:

AVBin loads, but generates an error when trying to make a sound.

@pvcraven pvcraven changed the title from Audio not working on the mac to Audio not working on the MacOS Dec 19, 2017

@pvcraven pvcraven added the bug label Dec 19, 2017

@pvcraven

This comment has been minimized.

Owner

pvcraven commented Dec 19, 2017

Spent about 5 hours on this today. AVBin DOES load. It just doesn't seem to recognize that fact any longer.

Tried updating to pyglet 1.4.0a1 and use ffmpeg. Managed to get ffmpeg to load. Unfortunately it gets a ValueError with NULL or seg faults. Won't even play WAV files.

@pvcraven pvcraven changed the title from Audio not working on the MacOS to Improve audio support Dec 29, 2017

pvcraven added a commit that referenced this issue Jan 2, 2018

pvcraven added a commit that referenced this issue Jan 2, 2018

pvcraven added a commit that referenced this issue Jan 2, 2018

@pvcraven pvcraven added this to Done in Release 1.3 Jan 11, 2018

@pvcraven

This comment has been minimized.

Owner

pvcraven commented Feb 11, 2018

Improvements delivered in 1.3.0. Still awful though.

@pvcraven pvcraven closed this Feb 11, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment