Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
97 lines (91 sloc) 3.2 KB
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = "x_do"
s.version = "0.1.2"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Victor Costan"]
s.date = "2012-01-13"
s.description = "Wraps libxdo using ffi, for high performance"
s.email = "victor@costan.us"
s.extra_rdoc_files = [
"LICENSE.txt",
"README.rdoc"
]
s.files = [
".document",
".project",
".rspec",
"Gemfile",
"Gemfile.lock",
"LICENSE.txt",
"README.rdoc",
"Rakefile",
"VERSION",
"lib/x_do.rb",
"lib/x_do/context.rb",
"lib/x_do/ffi_autogen.rb",
"lib/x_do/ffi_functions.rb",
"lib/x_do/ffi_lib.rb",
"lib/x_do/ffi_lib_ext.rb",
"lib/x_do/keyboard.rb",
"lib/x_do/mouse.rb",
"lib/x_do/window.rb",
"spec/spec_helper.rb",
"spec/support/stdlib.rb",
"spec/x_do/context_spec.rb",
"spec/x_do/ffi_lib_ext_spec.rb",
"spec/x_do/keyboard_spec.rb",
"spec/x_do/mouse_spec.rb",
"spec/x_do/window_spec.rb",
"tasks/ffi_codegen.rb",
"x_do.gemspec"
]
s.homepage = "http://github.com/pwnall/x_do"
s.licenses = ["MIT"]
s.require_paths = ["lib"]
s.rubygems_version = "1.8.15"
s.summary = "Ruby FFI for libxdo (X mouse / keypress injector)"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<ffi>, [">= 1.0.0"])
s.add_development_dependency(%q<rdoc>, [">= 3.12"])
s.add_development_dependency(%q<rspec>, [">= 2.8.0"])
s.add_development_dependency(%q<bundler>, [">= 1.0.0"])
s.add_development_dependency(%q<jeweler>, [">= 1.6.4"])
s.add_development_dependency(%q<rcov>, [">= 0"])
s.add_runtime_dependency(%q<ffi>, [">= 1.0.0"])
s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_development_dependency(%q<rcov>, [">= 0"])
else
s.add_dependency(%q<ffi>, [">= 1.0.0"])
s.add_dependency(%q<rdoc>, [">= 3.12"])
s.add_dependency(%q<rspec>, [">= 2.8.0"])
s.add_dependency(%q<bundler>, [">= 1.0.0"])
s.add_dependency(%q<jeweler>, [">= 1.6.4"])
s.add_dependency(%q<rcov>, [">= 0"])
s.add_dependency(%q<ffi>, [">= 1.0.0"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<rcov>, [">= 0"])
end
else
s.add_dependency(%q<ffi>, [">= 1.0.0"])
s.add_dependency(%q<rdoc>, [">= 3.12"])
s.add_dependency(%q<rspec>, [">= 2.8.0"])
s.add_dependency(%q<bundler>, [">= 1.0.0"])
s.add_dependency(%q<jeweler>, [">= 1.6.4"])
s.add_dependency(%q<rcov>, [">= 0"])
s.add_dependency(%q<ffi>, [">= 1.0.0"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<rcov>, [">= 0"])
end
end
Something went wrong with that request. Please try again.