Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

be more verbose in the 102 deprecation notice #5505

Merged
merged 1 commit into from Oct 25, 2020
Merged

be more verbose in the 102 deprecation notice #5505

merged 1 commit into from Oct 25, 2020

Conversation

@reaperhulk
Copy link
Member

@reaperhulk reaperhulk commented Oct 25, 2020

No description provided.

"cryptography you need to upgrade to a newer version of "
"OpenSSL. For this version only you can also set the "
"environment variable CRYPTOGRAPHY_ALLOW_OPENSSL_102 to "
"allow OpenSSL 1.0.2."

This comment has been minimized.

@alex

alex Oct 25, 2020
Member

We have not included this in previous OpenSSL version droppings, and instead referred people to the docs. Why now?

This comment has been minimized.

@reaperhulk

reaperhulk Oct 25, 2020
Author Member

Because I've fielded at least one question on StackOverflow where it turns out they broke their pip (due to the pyOpenSSL + cryptography on older pip/Python). They couldn't find the docs because we only keep them around for one version and I'd rather make it obvious how to fix it directly in the error.

@alex
alex approved these changes Oct 25, 2020
@alex alex merged commit bf4b962 into master Oct 25, 2020
20 checks passed
20 checks passed
Python 2.7 on macOS
Details
Python 3.5 on macOS
Details
Python 3.9 on macOS
Details
Python 2.7 on win32
Details
Python 3.5 on win32
Details
Python 3.6 on win32
Details
Python 3.7 on win32
Details
Python 3.8 on win32
Details
Python 3.9 on win32 Python 3.9 on win32
Details
Python 2.7 on win64
Details
Python 3.5 on win64
Details
Python 3.6 on win64
Details
Python 3.7 on win64
Details
Python 3.8 on win64
Details
Python 3.9 on win64 Python 3.9 on win64
Details
Travis CI - Pull Request Build Passed
Details
codecov/patch Coverage not affected when comparing ada53e7...bcac8cf
Details
codecov/project 100.00% (target 100.00%)
Details
docs/readthedocs.org:cryptography Read the Docs build succeeded!
Details
pyca/check Summary
Details
@alex alex deleted the reaperhulk-patch-2 branch Oct 25, 2020
@github-actions github-actions bot locked as resolved and limited conversation to collaborators Jan 24, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants