New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pip install may be broken with update to cryptography #702

Closed
nixonpjoshua opened this Issue Oct 12, 2017 · 3 comments

Comments

Projects
None yet
4 participants
@nixonpjoshua

nixonpjoshua commented Oct 12, 2017

Downloading/unpacking six>=1.5.2 from https://pypi.python.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl#md5=866ab722be6bdfed6830f3179af65468 (from pyopenssl)
  Downloading six-1.11.0-py2.py3-none-any.whl
Downloading/unpacking cryptography>=1.9 from https://pypi.python.org/packages/d2/3a/0ea50d3ef952e6fa39e3f2a21da86b19b41c4666f5ecea0a1ab4d1990d1f/cryptography-2.1.tar.gz#md5=d716e69826d31a6006669b060584fb3f (from pyopenssl)
  Running setup.py (path:/tmp/pip_build_root/cryptography/setup.py) egg_info for package cryptography
    error in cryptography setup command: Invalid environment marker: python_version < '3'
    Complete output from command python setup.py egg_info:
    error in cryptography setup command: Invalid environment marker: python_version < '3'```

This error is new as of today and wasn't present yesterday with no changes on my end I'm running a pip install pyopenssl --upgrade inside a docker file.

I looked and today the cryptography library was updated so it seems like there was a change there which broke this library since its looking to install any version greater than 1.9

I would appreciate any help or comments on why this might be happening

@nixonpjoshua nixonpjoshua changed the title from Pip install broken with update to cryptography to Pip install may be broken with update to cryptography Oct 12, 2017

@alex

This comment has been minimized.

Member

alex commented Oct 12, 2017

What version of setuptools do you have?

Can you try upgrading to the latest version of setuptools and seeing if that resolves the issue?

I'm going to close this, if that doesn't resolve it, levae a comment and I'll reopen.

@alex alex closed this Oct 12, 2017

@epixilog

This comment has been minimized.

epixilog commented Oct 25, 2017

This is a common issue due to outdated version of pip.

Try considering this command:
pip install -U pip setuptools

@bonsoirval

This comment has been minimized.

bonsoirval commented Feb 6, 2018

epixilog is correct. His solution worked for me. Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment