Permalink
Browse files

Require 5.5.9 instead of 5.6.0

  • Loading branch information...
1 parent 06ce8d5 commit 8959c369f8ad229f8ddec46d040d1e0870071d39 @cdujeu cdujeu committed Sep 21, 2016
Showing with 2 additions and 4 deletions.
  1. +2 −4 core/src/core/src/pydio/Tests/PHPVersion.php
@@ -32,7 +32,7 @@ class PHPVersion extends AbstractTest
/**
* @inheritdoc
*/
- public function __construct() { parent::__construct("PHP version", "Minimum required version is PHP 5.4.0"); }
+ public function __construct() { parent::__construct("PHP version", "Minimum required version is PHP 5.5.9"); }
/**
* @inheritdoc
@@ -41,13 +41,11 @@ public function doTest()
{
$version = phpversion();
$this->testedParams["PHP Version"] = $version;
- //return false;
- if (floatval($version) < 5.4) return FALSE;
+ if (version_compare($version, '5.5.9') < 0 ) return FALSE;
$locale = setlocale(LC_CTYPE, 0);
$dirSep = DIRECTORY_SEPARATOR;
$this->testedParams["Locale"] = $locale;
$this->testedParams["Directory Separator"] = $dirSep;
- if (floatval($version) < 5.4 && $locale != "C" && $dirSep != '\\') { $this->failedLevel = "warning"; return FALSE; } // PHP4 doesn't work well with foreign encoding
return TRUE;
}
}

0 comments on commit 8959c36

Please sign in to comment.