New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Inconsistent dependencies #1111

mohierf opened this Issue Feb 11, 2018 · 1 comment


None yet
2 participants

mohierf commented Feb 11, 2018

The requires:

install_requires = [

whereas the requirements.txt is:


The current Flask version is 0.12.2 and it is not compatible with Eve which raises an exception when it is installed:

Traceback (most recent call last):
  File "/home/travis/virtualenv/python2.7.14/bin/alignak-backend", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/home/travis/virtualenv/python2.7.14/lib/python2.7/site-packages/pkg_resources/", line 3147, in <module>
  File "/home/travis/virtualenv/python2.7.14/lib/python2.7/site-packages/pkg_resources/", line 3131, in _call_aside
    f(*args, **kwargs)
  File "/home/travis/virtualenv/python2.7.14/lib/python2.7/site-packages/pkg_resources/", line 3160, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/travis/virtualenv/python2.7.14/lib/python2.7/site-packages/pkg_resources/", line 668, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/home/travis/virtualenv/python2.7.14/lib/python2.7/site-packages/pkg_resources/", line 681, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/home/travis/virtualenv/python2.7.14/lib/python2.7/site-packages/pkg_resources/", line 870, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'flask<=0.12,>=0.10.1' distribution was not found and is required by Eve

The problem is that some Eve relaed packages do not set an hard dependency on a specific version (eg. flask-apscheduler or flask-bootstrap) and it installs the 0.12.2 Flask version that is not compatible.

It may be possible to allow using Flask 0.12.2 ?


This comment has been minimized.


nicolaiarocci commented Feb 14, 2018

Yes, this needs a fix. Thanks for reporting.

@nicolaiarocci nicolaiarocci added this to the 0.8 milestone Feb 22, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment