New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop support for Python 2.6 #1129

Closed
nicolaiarocci opened this Issue Mar 28, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@nicolaiarocci
Member

nicolaiarocci commented Mar 28, 2018

Official support for Python 2.6 ended 4+ years ago. Supporting it has a cost (see #1128). Consider deprecating it with v0.8, or dropping it altogether. I am in favor of dropping it.

@nicolaiarocci nicolaiarocci added this to the 0.8 milestone Mar 28, 2018

@nicolaiarocci

This comment has been minimized.

Member

nicolaiarocci commented Apr 4, 2018

Going to follow the directives for dropping support for older python versions

  • v0.8 adds the python_requires metadata
  • it is the last Eve version to offer support for Python 2.6
  • changelog states that Python 2.6 is now deprecated
  • a subsequent release (ideally, 0.9) will drop Python 2.6

This way, when/if someone with Python 2.6 tries to install eve, he/she gets v0.8, even when 0.9+ is available.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment