New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

PyQt5 searching for accessible dir on Mac #2577

Closed
thiagofmam opened this Issue Apr 26, 2017 · 8 comments

Comments

Projects
None yet
3 participants
@thiagofmam

thiagofmam commented Apr 26, 2017

Hi,
When I try to execute the .app on Mac and get this error:

QFactoryLoader::QFactoryLoader() checking directory path "/Users/thiagomeneses/PycharmProjects/interact-ii/main.app/Contents/MacOS/accessible" ...
Could not find QtWebEngineProcess
Abort trap: 6

@ghost

This comment has been minimized.

ghost commented May 10, 2017

Does this work with #2519 applied?

@ghost

This comment has been minimized.

@thiagofmam

This comment has been minimized.

thiagofmam commented May 19, 2017

I got this error:

git pull +refs/pull/2519/merge
fatal: '+refs/pull/2519/merge' does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights

@ghost

This comment has been minimized.

ghost commented May 19, 2017

How about this?

git pull origin +refs/pull/2519/merge
@thiagofmam

This comment has been minimized.

thiagofmam commented May 19, 2017

Perfect.

Now I got other error.

This application failed to start because it could not find or load the Qt platform plugin "cocoa"
in "/Users/thiagomeneses/Qt5.8.1/plugins/platforms".

Available platform plugins are: cocoa (from /Users/thiagomeneses/Qt5.8.1/plugins/platforms), minimal (from /Users/thiagomeneses/Qt5.8.1/plugins/platforms), offscreen (from /Users/thiagomeneses/Qt5.8.1/plugins/platforms), cocoa, minimal, offscreen.

Reinstalling the application may fix this problem.

@ghost

This comment has been minimized.

ghost commented May 19, 2017

Googling the problem revealed this on stackoverflow.

As a side note, we may consider adding a dependency on osxrelocator. Perhaps you can help on this matter if you have time?

@thiagofmam

This comment has been minimized.

thiagofmam commented May 19, 2017

Yes. I can verify.

Thank you very much.

@bjones1

This comment has been minimized.

Member

bjones1 commented Jan 31, 2018

I'm closing this, since #3233 should fix it -- see the instructions there.

@bjones1 bjones1 closed this Jan 31, 2018

@htgoebel htgoebel added this to the PyInstaller 3.4 milestone Sep 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment