New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pygobject gtk3 linux typelib xlib2 not found #2634

Closed
thiolliere opened this Issue May 30, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@thiolliere
Contributor

thiolliere commented May 30, 2017

with pyinstaller develop on linux when packaging:

import gi
gi.require_version('Gtk', '3.0')
from gi.repository import Gtk

print("tototototo")

on another linux machine the result is:
gi.RepositoryError: Typelib file for namespace 'xlib', version '2.0' not found

add xlib-2.0.typelib in gi_typelibs seems to solve the issue.

@thiolliere

This comment has been minimized.

Contributor

thiolliere commented May 30, 2017

well on a virtual machine with debian jessie I have now a segmentation fault

@virtuald

This comment has been minimized.

Contributor

virtuald commented May 31, 2017

Hm, that typelib should have been picked up. What version of pygobject/gtk is it?

@thiolliere

This comment has been minimized.

Contributor

thiolliere commented Jun 1, 2017

well I don't remember in what environment I made it.
It may be that I build on a system that hasn't gtk installed.

@thiolliere thiolliere closed this Jun 1, 2017

@htgoebel htgoebel added the invalid label Jun 7, 2017

mgautierfr added a commit to mgautierfr/pyinstaller that referenced this issue Jun 14, 2017

Add missing gi.repository.xlib hook
PyInstaller need a hook to correctly import `gi.repository.xlib` module
and the associated files.

Fixes pyinstaller#2634

thiolliere pushed a commit to thiolliere/pyinstaller that referenced this issue Jul 24, 2017

Add missing gi.repository.xlib hook
PyInstaller need a hook to correctly import `gi.repository.xlib` module
and the associated files.

Fixes pyinstaller#2634

thiolliere pushed a commit to thiolliere/pyinstaller that referenced this issue Jul 24, 2017

Add missing gi.repository.xlib hook
PyInstaller need a hook to correctly import `gi.repository.xlib` module
and the associated files.

Fixes pyinstaller#2634

mgautierfr added a commit to mgautierfr/pyinstaller that referenced this issue Mar 12, 2018

Add missing gi.repository.xlib hook
PyInstaller need a hook to correctly import `gi.repository.xlib` module
and the associated files.

Fixes pyinstaller#2634

htgoebel added a commit that referenced this issue Mar 13, 2018

Hooks: Add missing gi.repository.xlib hook.
PyInstaller need a hook to correctly import `gi.repository.xlib` module
and the associated files.

Fixes #2634.

@htgoebel htgoebel added this to the PyInstaller 3.4 milestone Sep 2, 2018

cowo78 pushed a commit to cowo78/pyinstaller that referenced this issue Dec 7, 2018

Hooks: Add missing gi.repository.xlib hook.
PyInstaller need a hook to correctly import `gi.repository.xlib` module
and the associated files.

Fixes pyinstaller#2634.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment